Cannot get HQPlayer to work with Roon, ZEN Stream and Mytek Brooklyn +

I cannot get HQPlayer to work with Roon, ZEN Stream and Mytek Brooklyn +. While ROON works in a completely stable way with ZEN Stream and the MYTEK and can send DSD256 to the DAC, HQPlayer seems not only a bit unstable (Some times adding static noice), but also seems to loose connection to the DAC (The display of the mytek says ‘no connection’) even if the music continues to play.

I have tried to set up HQplayer with the Zen stream as a NAA! What is perhaps most weird is that it works the first day I setup the new system. But then it deteriorated with static noice plus the lack of connection. I wonder if any of you would be able to give me some advice of how to set up HQplayer so it works!

Hello Morten

I’m using Roon & HQP on a m1 mini and Zen Stream in NAA only mode USB to a Zen Dac Signature V2.

In 5 months of using 24/7 this setup I had only 2 errors in roon “lost the device”.
Do not forget to disable the dac from roon.
The sequence of powering on the devices I think it matters. Power the dac, wait to boot, power the Zen (I use only NAA mode), wait to boot, open HQP and select the NAA usb.

As trouble shooting I would try another dac if you have, also I would try Mytek USB direct from the HQP running comp.

I can share screenshots if you want.


Thanks a lot Traian - This worked! Now major problem is that it is still a bit unstable!

1 Like

You are welcome

unstable meaning?
dropouts, roon loses the playback device, or other error?

I can only think to ask how is your network? if 256 from roon is stable try lighter filters and modulators in hqp and go higher step by step maybe to see where the problems appear. Are roon and HQP on the same computer? the comps and zen are all connected to the same switch? is the switch managed? if managed turn on flow control. Any firewalls? Maybe I would try also to set fixed ip’s for all the devices.

Please make sure you don’t accidentally send DSD at multiples of 48k to the Mytek. Because it won’t work and will produce noise.

48k DSD doesn’t work with Mytek, so it must not be enabled. And thus Adaptive rate must be disabled too.

Here, for Mytek max 44.1k x256 rate limit.

And thus 1x filter cannot be sinc-MGa, but instead for example the default poly-sinc-gauss-long.

1 Like

Thank you, I did not think of that.

Thank you Jussi now it plays. The 48K produce noice! Thanks also Traian for the advice on the network.

1 Like

For some reasons HQplayer still loose the connection. I have HQplayer and Roon on the same iMac - they are connected to a basic switch, which is the same for the ZEN stream, which is then connected by USB to the MYTEK Brooklyn +

If the HQplayer is supposed to be as stable as ROON there is something weird going on. ROON works perfectly all the time is extremely solid in comparison (also with upsample to 256DSD)…it is s shame because I find that HQplayer sounds the best.

And you have made sure the Mytek is disabled in Roon Settings → Audio when using HQPlayer?

Does HQPlayer work reliably standalone, when Roon is not running?

Just in case, power down ZEN Stream, set it to NAA Exclusive mode with the rotary switch in the rear and power it up again.

It seems to work. Now it is stable. Thanks Jussi!