Cannot get Roon ARC to Work Externally & Intermittent Roon Playback Driving Me Crazy…

Roon Core Machine

Hello there,

I am having 2 issues with Roon that are keeping me up at night that I would love some community support on:

  1. Roon ARC:
    I have been trying to get Roon ARC to work for months now and just keep getting the same error -

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“73.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

I am running Roon version 2.0 build 1193 on a MacBook Pro (2015), Mac OS Monterey V 12.6.2, iPad Pro and iPhone 14 Pro Max. All devices give me the same error.

My roon core is a Innuos Zen Mini MK3 LPSU, firmware 2.2.5

My network is a Netgear C3700 modem and Orbi RBR50 mesh system.

I’m not the most technical person but would appreciate any step by step notes on how to configure my network to be able to run Roon ARC externally. I can see it in my home network. I just can’t outside of my home.

  1. Roon Playback:
    I continue to get spotty Roon playback all day in my office where my roon core is connected directly to my router. Same specs and setup as above. I get intermittent song playback as well as the Uh Oh Something’s not right and Roon wheel spinning throughout the day. I rarely make it through 2-3 songs without this happening. Like I said, I have my Innuos Zen Mini MK3 LPSU set up via Ethernet going into my Orbi router and my Naim Uniti Atom plugged in directly via Ethernet into the same router so I’m surprised that I continually have this issue. I have had Innuos tech support directly connect to me Zen Mini on 3 occasions and they cannot determine any issues with the Zen Mini on their end.

So, Roon and Roon ARC are both falling on hard times over here. Would appreciate any insights on what to do to get the system working properly!

Many Thanks,
Carey

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi @Carey_Head,

Welcome in the community, a fellow community member here.

The reason Arc isn’t working, is that you have multiple layers of NAT translation.

Just to be sure, is your gear attached on the Orbi? If so, i would suggest you check if your Netgear C3700 can set in bridge mode.

Take a look at below post, here you see how to set your Netgear C3700 can be set in bridge mode

Kind regards,

Maarten.

Hello.
I had the same problem with the error saying multiple NAT. I was able to get around it with the Meshnet feature in the NordVPN client. It involves creating a network of trusted devices that connect directly to each other, bypassing NordVPN servers. You install the NordVPN client on each device and add your trusted devices, which then see each other regardless of what network they are in (more precisely, mobiles see the computer). I call it an extended home network. The ARC test will still return some error, but it works.

I use it with Roon Core on Windows 10 and with Samsung devices (smartphone and tablet). NordVPN should also work on Apple devices. Except that I have Roon Core on a PC where NordVPN is running. I’m not sure how it would work for you, where Roon on Macbook is just a client and Core is on a separate device.

There is also the option to run NordVPN on the router itself. You would need to check if your router supports Nord. My TP-Link supports, but unfortunately there is no NordLynx protocol in the settings yet, on which Meshnet works. On the router, you can set which devices in your home network are to be connected to Meshnet and which are to be connected directly to the Internet.

Of course, the NordVPN service is an additional cost, but at the moment there seems to be a New Year’s discount for 2 years.

Best regards and I hope this helps, or at least make easier to solve your problem.

As @Maarten_Duits said above, it is quite clear from the error message that you are getting that you have a multiple NAT situation. So both your Netgear C3700 AND your Orbi are acting as DHCP - so you are getting IP addresses from both. I’m surprised you are not getting occasional messages on other devices that 'Your IP Address is in use by another device".

Simple solution, as Maarten states, switch the C3700 to bridge mode, or set your ORBI router to AP mode. One device as DHCP.

1 Like

Hi @Slawomir_Kubicz,

Great you post your solution here. If you have NordVPN then is see this is a way to solve the problem. But in my opinion, we should first look to get it work without any further costs.

Kind regards,

Maarten.

So, the simpliest way I didn’t mention, is to obtaining a static/public IP from the Internet provider, but in my opinion it exposes our local network to more threats from the internet. I used the option with NordVPN because I had already purchased the service and I have it until October 2023. What will happen next, I don’t know. Maybe I’ll ask my ISP for a public IP myself.

That won’t help the user. The nat issue for this user is caused by having two or more routers plugged together.

Carey, you mentioned netgear and orbi, do you also have a comcast box?

1 Like

I see. So it’s not just a matter of public IP and I would still have a NAT problem if I resigned from the NordVPN service. I use fiber that goes straight to the Dasan unit and from there via LAN cable to the TP-Link router. When I once connected a PC with Roon Core directly to Dasan to check if the multiple NAT error would still happen again, the ARC test repeated this error, only with a different external IP. It seems that another NAT must be set up with the ISP.

Hi @Carey_Head,

Thank you for posting and we’re sorry to hear you’ve had a deflating experience with ARC and Roon recently. I’ll provide next steps to restore playback in each app below:

  1. In ARC, please see @Rugby’s comment above. If Comcast is your ISP and you have a Comcast-supplied modem, then that unit will need to be placed in “Bridge” mode as mentioned above to remove the MultipleNAT issue.

If you do not have an additional modem in your setup, and the Netgear/Orbi boxes are your only other hardware equipment, then please follow the steps @Maarten_Duits shared above.

  1. Regarding Roon and intermittent playback, diagnostic logging from your Core confirm there is network disruption causing routine dropout on multiple endpoints. I recommend a few steps to try to stabilize the network:
  • Many users have a better experience if they change their main router’s DNS servers from the ISP-provided server (Comcast, in your case) to Cloudflare DNS, Quad9 or Google DNS.
  • Verify the Orbi firmware is updated and that multicast is enabled across your network hardware.
  • Clear your Tidal cache:
1. Exit out of Roon
2. [Find and open your Roon database](https://kb.roonlabs.com/Database_Location)
3. Navigate to `Roon/Cache`
4. Move the contents of the `/Cache` folder elsewhere, like your desktop
5. Try restarting Roon and verify if the issue still occurs

Lastly, this Core appears to be on a different build than your Remotes, causing authentication issues. Please update all your devices to the latest build to further stabilize conditions. As a final and more thorough step, you can generate a new RoonServer instance as well:

1. Create a Backup of your current Roon database
2. Exit out of Roon
3. Navigate to your Roon’s Database Location
4. Find the folder that says “Roon” and “RAATServer”
5. Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
Reinstall Roon from our Downloads Page

We’ll be watching for your response. Thank you!

1 Like

Thanks much. I just got a new Netgear AX2700 modem and a new Orbi AX6000 WiFi 6 system. My modem died yesterday. :flushed:

Internet is through Xfinity but it’s my own modem.

The new gear I hope will solve the connection issues. Seems to be helping a lot there so far.

Any idea which path to take for ARC with the gear mentioned above?

I just tried setting up ARC again with this new setup and got this error:

Many Thanks!

Hi @Carey_Head,

We’d be happy to take it home from here. Three quick suggestions based on the most recent diagnostics:

  1. Verify UPnP is enabled and updated on the new Netgear modem.

  2. You’ll want to place the Netgear modem/router in bridge mode if your Core is connected to the Orbi WiFi network. Here’s a guide.

  3. Roon is currently attempting to use UPnP to connect to ARC, according to diagnostics, but it can also connect via manual port forwarding. Other users (like in this thread, for example) have had better luck with the latter method on Orbi router setups. If the above steps don’t help, then we’ll try setting a manual port forwarding rule in the web admin of both the Orbi and Netgear routers pointing to the static IP and port listed in Roon → Settings - ARC from your screenshot.

Hang in there! We should have ARC up and running soon.