Cannot group zones in 1.8


Full disclosure, I never really tried to group zones in previous versions, but the tutorial I found via google made it look simple.

This process, however, is not working for me in Roon 1.8. There is no option to group zones when selecting the zone icon in the lower right, just a a GUI showing the current zones.

What am I doing wrong?



Sonore ultraRendu with Lampizator DAC using Amanero technologies combo384 amanero

KEF LS50 wireless

Core on Sonictransporter 1.5

Which zones are you trying to group. You can only group RAAT zones or zones that are of the same heritage, ie Sonos with Sonos, Meridian with Meridian, Chromecast with Chromecast.
Does that make sense?

Chris, All,

Thanks for the response, but honestly, it does not make sense. I am just trying to send the same music to two different devices in my house. One being a Roon ready ultraRendu and the other being a pair of Roon Ready KEF ls50 wireless speakers. Since they don’t group, Does that mean these two devices work on different protocols? If so, why is this a limitation…


Have a look at the Knowledge Base for details on your particular circumstance

I easily group my Meridian 210 Roon Ready endpoint with my Bluesound units. Both use RAAT.
I cannot group my Meridian MS200 with these units. ( I don’t need to)

The KEF speakers are “Roon Tested” - NOT “Roon Ready” so they cannot be grouped with Roon Ready devices. As you say, they use a different connection protocol.

I don’t see a Zone Picker option. Where is it? Before it was very easy to get too.

I answered the same question earlier for someone else.

Click on the zone icon and then the group button

Sorry, but I did not see the group button.Does it mean that all my devices are unable to work in a group ?
I used some Raumfeld device via chromecast and a Hifiberry device as a roon bridge.

You cannot group a Chromecast Zone with a RAAT Zone (the Hifiberry device running Roon Bridge). That’s why you don’t see the Group icon. It will only appear if you start with a Zone where other Zones of the same type are present and active.

But for my chromecast devices , all from the same type , I see also not Group icon ?

As this article points out, you can’t group Chromecast devices in Roon - you have to use Google’s Chromecast app to do that.