Cannot play to airport express group in sync

@eric, I jump in this old discussion wondering if a solution has been found.
I’ve just set up a NUC7i5 and moved my Core from an iMac -which worked great- to stream to several Airport Express just to find the same problems reported here.
Just this morning I had tree Airplay zones grouped playing ok, when I noticed one was out of sync. Then I tried switching on and off in turn the 3 Airport Express but problem got worse and couldn’t have them playing together or sometimes couldn’t play at all (animation in the zone list, but no progression in the player at bottom screen.

I also noticed that ROCK is not picking my Airport Express in the correct 10.0.1.X , but in 169.254.x.x IP, which I found to be a self assigned (by the device) IP address. Could this be part of the problem?

Hoping there’s a solution to this, as I love ROON and I have just invested in a lifetime subscription, and moved from my iMac (which worked ok) to NUC in order to have a rock (pun intended) solid environment to stream my music around the (two storey) house.

Hello @Marco_Sassone,

When you see the 169.254.x.x IP addresses for the airplay devices, do you have an iOS device plugged into your iMac via USB?

Also, I have moved your post to a new topic in order to keep attention focused on the issue you are seeing with the new hardware.


Thank you @john for your reply.
No, no iOS device is plugged in any Macs (Imac or my wife’s MacBook Pro).

I noticed the Apple TV is seen by ROCK with its proper IP address, while the other 3 Airport Express(es) are seen on a different IP (169.254.x.x ).
AirPort Utility reports the correct IP address for all the 3 Express and AppleTV (10.0.1.x).
I took a screenshot of this (ROCK on the left, Airport Utility on the right) :

I’ve just replicated the problem, by starting playing through Apple TV.
All ok, then grouped it with Airport and nothing plays anymore.
Then by fiddling a little with play/pause, music is now only playing from Airport 2 (where ROCK is connected by CAT5 Ethernet wire to the LAN, by the way) and there’s no way to get sound from Apple TV, not even on its own. Animation is on in the Zones list on the right of Roon UI, PAUSE sign is showing at the bottom on timeline (so the track should be playing), but time and the thin red pointer are frozen.
Simply there’s no signal being sent to the Apple TV.
The same happens when it’s an Express not playing: the optically-connected DAC (Denon DCD-2010AE SuperAudio CD player) display doesn’t show any signal, just shows "OPT IN " instead of “EXT IN 44,1 K” when it’s working correctly.

The weird thing is, when I tried restarting the Express2 and this was visible again in Roon, initially it showed the right IP (10.0.1.x) but reverted after a split second to 169.254.x.x

I think I’ve read somewhere that these 169.254.x.x are the self-assigned IP addresses used by the Airport Express to be reached and configured when are brand new or after a reset.

I wonder why ROCK is picking these IPs instead of the ones given by the DHCP and furthermore, why is picking right one for the AppleTV ?
Is this what causes the Zones grouping problem ?

PS: still no sound from Apple TV… even by Transferring signal from the correctly playing Express Zone. Dead silent… and frozen player

Sorry for any obvious technical mistake, I’m no network expert

Can you tell us the full topology of the network, including all networking equipment and how everything is connected?

That will help us understand what’s going on here. Then I’m sure we can get this stable for you @Marco_Sassone – thanks!

Hi @mike, as I’m no network expert, I thought to draw a layout to simplify things.
Hope it’s clear and helps to find a solution:

1 Like

forgot to mention:
the Vodafone modem 300MB fibre, has WIFI turned off.
The AIRPORT EXTREME is generating the WIFI (2,4 and 5 GHz) and DHCP 10.0.1.x
EXPRESS 2 is extending the same network and is connected via CAT5 to EXPRESS 3, on the above floor, which generates a NEW WIFI with the same name and password (found on Apple knowledge base it’s the best way of doing this, instead of keep extending).
NUC-ROCK is wired (CAT5) connected to EXPRESS 2 and, when has WIFI turned on, is given IP

well, I tried again and I had it working (all three zones-systems playing together and in sync)!
Then played a little by grouping and ungrouping zones and it got messed up again.

Now I can play/stop/play from AppleTV and Express 4, but no sound from system onExpress2, where NUC is attached.

I kind of ‘woke up’ the Express 2 turning it on and off from iTunes and it’s all working again.
Tried all 3 zones and it’s ok.
So it seems the Express(es) go into a frozen mode for some reason and Roon is not capable to reach them (although still sees them).
Still the IP in Roon Audio pref panel are misteriously in the 169.254.x.x realm …

But at least I can listen to music with Roon on the three systems, for now.
(well I could with iTunes too, but Roon it’s better, as long as it keeps working reliably)

quick update: music has been playing for about 3 hours now, but I’ve just noticed the audio was out of sync between AppleTV and Airport 2.
Tried ungrouping/grouping, pause/play several times, but I can’t have music out of Express 2 now.
Again, waking by selecting and playing Express 2 from iTunes seems to have made the trick.
Tried playing from iTunes through all three endpoints together (2Express and AppleTV) and all worked ok and in sync.
Switched to Roon and all is working and in sync.

… and it just happened again. While playing, AppleTV stopped for a split sec, then started playing again, but out of sync.
Pausing/playin Roon lost control of everything and couldn’t get sound out.
Going to iTunes, playing from the AppleTV, did the trick again.
Now all zones are playing from Roon, in sync.

hi @mike, my setup is still suffering from this annoying behaviour when playing to three Airplay grouped zones.
When I manage to have all three zones playing in sync, after pausing or jumping tracks most of the time one of the zones isn’t playing or is out of sync (seems to be always the Apple TV). I believe the problem lies in the different IP addresses seen by ROCK.
Just wondering if you guys at support have been able to replicate the problem and if there are any news about a possible solution.
I’d really like to have this system working, as it’s how we listen to music ‘socially’ at home, with music diffused over the two floors, with more remotes (iPhones /iPad) well aware of the limitation in SQ of the Airport stream with high res files.
For critical listening I have a DAC (AudioQuest DragonFly Red) directly connected to the NUC and to the main system (Bryston PS20 pre/4BST power + Dynaudio Focus 220). I know most people would cringe at having the DAC directly attached to the NUC, but to my ears it sounds great (but I’ve been reading extensively and I’m looking into USB conditioners and stuff…)


Hello @Marco_Sassone,

We have spent many hours attempting to replicate this issue in our QA lab, and we believe we may have identified a possible mechanism that would cause the behavior you are seeing. I can’t make any promises on if this will resolve your issue, but I just wanted to give you a heads up that we are continuing to investigate and iterate in order to get things back up and running for you. We hope to have this fix included in an upcoming release to the Roon client.


Thank you @john for the update, I was actually wondering if someone was looking into this. I really appreciate it.
The issue keeps happening and I’m looking ffwd to a fix in the next update. (And maybe a new feature for properly tagging large multi cd box set :slight_smile: )

well @john I’ve just been notified and I updated to Build 401 and … it 's 1000 times better! :smiley::smiley::smiley:
Not quite perfect, but whenever (much much less) sound goes out of sync (when it happens it’s always in between tracks or when skipped/ffwd by user) it’s far easier to get it back in sync (just pause/play all zones)

It downed on me to try and set the Crossfade time and all the other settings to the same value on each Airplay device ungrouped and the same to the grouped zone and it seems to be working better (so far).

What now seems rock solid is the link with the AppleTV, which before was easily lost, and regained only by Disable/Enabling it. Now AppleTV works every time without need to do so.

I know Airplay is not the best way to stream music because the SQ limitations, but it’s still a convenient way for people like me with an already Extreme/Express wifi setup in their home - for casual/background listening, of course.

It’s very late over here, but tomorrow I’l try more extensive tests and enjoy the new features in the new build.
For the time being, Thank you!.

Hello @Marco_Sassone,

Glad to hear things have improved with the update! We continue to monitor the situation regarding reports of less than ideal Airplay sync; investigative work is ongoing. Thank you for the effort and information you’ve provided us during the troubleshooting process, it has been helpful for us in figuring out the conditions necessary to trigger this behavior.


thanks @noris. Problem solved

One last thing, just wondering if you guys at Support have any news on my Issue 3, of grouped Airplay endpoints randomly going out of sync, as it just happened minutes ago. After an hour or so of good play, suddenly happened in Roon Radio mode. Not a big deal, but just worth mentioning.

Issue 3
Around a year ago I reported a problem of out-of sync grouped Airplay endpoints.

in which @john helped and the situation got much better.
Unfortunately, I have to report the issue is sometimes, much less, but still happening.
Just worth reminding that two of the three Airplay endpoints (all Airport Express + 1 AppleTV 3rd gen) show a different IP than the network I set up and expect to see(

Hi @Marco_Sassone,

I’ve moved this issue back into the existing thread, it’s better to have all the information surrounding the issue in one place.

I will discuss your case with John again at our next meeting, but can you please reproduce this issue and let us know the exact local time + date + track/station it occurs on?

Thank you @noris,
tomorrow I’ll let the music play and try to take note of when and if it happens again.
A detail that could help to frame the issue:
yesterday it happened using Roon Radio (which I use locally, from my library, as I don’t have external subscriptions with Tidal or Qobuz), hence picking a track from different albums.
I’ll let you know.
I’m no network expert, but what seems weird to me is that my Airports are seen all in the 10.0.1.xx realm by Airport Utility (V 6.3.9), while Roon sees in that realm the AppleTV only, and all the others in

I more frequently group the AppleTV with the Bryston Airport 2, as the two audio systems are in the same big room, and the out of sync here is very noticeable (while the Audiolab Airport 4 is on the upper floor)

This is a self assigned IP address and is indicative of the device not getting an address from the DHCP server in your router(normally)

thank you @wizardofoz,
my set up is how I posted at the beginning of this thread,
with my fiber modem with WiFi off, connected to my Airport Extreme which is generating my wi-fi and giving the DHCP addresses to all devices.
My devices’ IPs are a little different now than in the drawing, but all in the 10.0.1.xx (this is confirmed with Fing app too).
As I said, I’m no network expert, and I don’t know how your info is pointing me to a solution…

It’s pointing you to an issue… as they are showing a self assigned address roon might not be able to find then so reboot them or hardwire them as it’s possibly flakey WiFi or networking,

Apple networking products have been identified as problematic in the knowledge base