Cannot see Crestron Extension in Roon? [Resolved]


(Dwayne Carter) #1

Hi

I was hoping someone can help me. After spending the weekend pulling my hair out…I decided to reachout to you all. I have downloaded the latest Crestron modules, but have hit a wall.

Under ROON Extensions, NO Crestron (or any) extension show up?
In looking at the program…HOW does crestron even know that the Roon (Nucleus +) is even there? No place (that I can find) asks me for the Nucleus_ IP address or anything? What am I missing?

Generally, with Crestron, you add an Ethernet module, add the device IP address…and you are on your way?

In the Example module, I see the Roon System Module…but no connection reference? The direction (manual) is bare (to say the least).

Can anyone help out?

Dwayne


(Noris) #2

Hello @Dwayne_Carter,

Just to confirm, you have downloaded and installed Build 6 of the Crestron module from the Knowledge Base, correct?

You don’t need to point the module to the Nucleus IP address because we are not communicating with the Nucleus directly, the Crestron module communicates with the Roon API and the API forwards commands from the Crestron module over to Nucleus.

If you open your Roon Settings -> Extensions, do you see any zones pop up there? It should look like this when it’s working properly:
image.

If there are no zones popping up under the Extensions then the module has not established proper communication, I would recommend:

  1. Rebooting your Nucleus
  2. Reboot the Processor
  3. Perform a recompile all and upload the module to the processor again

Please let me know if that works and we can continue from there.

Thanks,
Noris


(Dwayne Carter) #3

Noris…THAT WORKED!!!

SOOO simple. Thanks for responding on a weekend!! You guys Rock!


(Noris) #4

Hello @Dwayne_Carter,

Happy to help! If there’s anything else just let us know and we can take a look :slight_smile:

Thanks,
Noris


(Dwayne Carter) #5

The only odd thing? When in Settings (Extensions), changing ONE room name…changes the remaining 4?


(Noris) #6

Hello @Dwayne_Carter,

That’s very odd and should not be happening. Hmm, I am wondering if the settings incorrectly transferred over between uploads. Can you please go into your Roon Settings -> Extensions -> Authorizations and remove all of the Crestron extensions present, perform a recompile all in SIMPL, and then upload the program once more?

The Authorizations screen should look like this and you can press to remove the Crestron extension and it should show up again when you reupload:

Thanks,
Noris


(Dwayne Carter) #7

Noris…that got it! Weird. Oh well…it works well enough for now!!

Thanks again!

Dwayne


#8

This topic was automatically closed after 20 hours. New replies are no longer allowed.