Can't add station manually

Station is here:

http://stream.amazingradio.com:8000/stream.mp3

Result is here:

There is a redirect at the above URL, redirecting to one of several streams (stream1.amazingradio.com:… through streamx.amazingradio.com: …), but I tried typing in an actual stream–that works–with the same result.

Needless to say, searching for “amazing radio” and “amazingradio” yielded no relevant results.

Jim

Hmm. I’m getting the same results. The response from a direct query is

301 Moved Permanently

AmazingCast 1.0

Need to explore further…

Inspecting the output from amazing radio website shows the same redirection going on as you found. Other sites used the same stream although Tunein baulked with an SSL protocol error.

I was only able to connect manually via a Linux Curl when I added the “?redirect=1” to the string, otherwise I got “Empty reply from server”. I did establish that it is a VBR MP3 stream.

All of this is purely background to say that

  1. We can’t add streams to Roon radio that require a query string.
  2. You can’t add it as a tunein station because tunein won’t play the stream.

Sorry.