Can't connect Roon to my Synology NAS

Roon Server Machine

Core: Silent Angel Rhein Z1 V2
Remote: MacBook Pro M1-2020

Networking Gear & Setup Details

Synology DS218+ on Ethernet/Wired

Connected Audio Devices

Linn DS3

Number of Tracks in Library

Description of Issue

Roon fails to connect to the NAS, keep getting error messages.

Can someone help me with the correct NAS settings for a shared folder.It has worked but after restarting the Silent Angel and NAS I can’t get connect to Roon anymore.

Assuming the Silent Angel is not running Windows, you should use the smb://196.168… rather than the \\192.168… notation.

I get invalid network path

Did you specify the correct ip address of your NAS?
The screenshot shows 192.168.xx.xx, which is not a valid address. (I just assumed you wanted to obscure it, which is not necessary as 192.168 addresses are private and not accessible outside of your network.)

Perhaps you can try to connect from your Mac to the NAS using the same path in order to validate it?

Thanks for your reply…I’ve used the correct address.
Before I’ve restarted the Silent Angel and my NAS it worked perfect.

If you relying on DHCP the IP could possibly have changed on your NAS. I recommend statically assigning an IP or creating a DHCP reservation for the NAS. I would also recommend creating a server name under the NAS’s network page so it can be found on your local network even if the IP does change…

Thanks Brian,
As you can see on the screenshot below, the IP is not changed and I do have a sever name.
What I don’t understand is that everything works well if I use the Linn app?

Scherm­afbeelding 2024-02-03 om 09.52.47

his looks like you are not directly connecting to the NAS but rather the quick connect agent from Sinology. Try in a browser or http://Naslinn.local:5000. And when mapping the drive to a PC or Mac you would use smb:// or smb://Naslinn. in Roon storage you would // or //Naslinn. Still though if you are not statically assigning the IP in the NAS network area or have a DCHP reservation the IP does have the possibility to change if the router that is issuing DHCP or the NAS loses power for any extended period of time…

Also you need to go to file services in the NAS and under SMB enable it to map the drive.

It seems that you had a similar issue a few times before. In one of those cases, your path included a space. Perhaps you could also share the exact network share location as you typed it? Similar to your original post, but then unredacted. The slightest typo will cause this to fail.

The exact network location is: \\Muziekbibliotheekx

Could it be a solution that I re-install the Silent Angel and Roon completely? and if yes, what Will be the best way to do this?
I’ve tried all your recommendations but no succes up til now.

I keep trying, but no success. I don’t understand because it has always worked. The only thing I can do now is to use the Linn app, which will do recognize my NAS.Too bas, because I have a lifetime subscription for Roon.

Have you tried being less explicit about the file path? You should just connect to the base NAS server, and not try to specify a shared folder in the smb path. (In your case, that would appear to be smb://NasLinn, or \\ WITHOUT Musiekbibliotheek) Once you connect, Roon will then allow you to select any & all available shares (such as Musiekbibliotheek), presuming you have set their permissions properly for the logged in user, for scanning, e.g.:

Thanks for your reply.
I’ve tried and I don’t get a error message, but nothing is happening.
See screenshot below.

I don’t see that you populated it with a username and password

Same result

Next: is your Synology DSM firewall on by any chance?

No, firewall is not on.

Which levels of SMB do you have enabled?

Can you share a screenshot of your SMB settings, including the advanced settings?