Can't connect to Roon core on QNAP from Pixel 2 and Pixelbook


I can’t connect to myroon core from my Pixel and Pixelbook but I can connect from my windows pc. The only time I can connect with the pixel and pixelbook is if I stop and restart the Roon app on my QNAP

I have an Orbi router and have tried to toggle the “Disable IGMP Proxying” setting per another post but it does not resolve my issue.

My setup

Roon core
Version : 1.5 (build 334) stable
QPKG-Version : 2018-06-14

ORBI Router V2.1.4.16

Android version 8.1.0
Chrome OS Version 67.0.3396.99 (Official Build) (64-bit)

Hello @John_Cale,

Thanks for contacting support, I’d be happy to take a look over this issue with you. It seems to me that there may be some network instability here preventing the connection of the Pixel and Pixelbook to the QNAP, can you please let me know the full topology of your network setup?

Please let me know if the QNAP is connected directly to your Orbi router via Ethernet or Wifi, is the Pixel and the Pixelbook connected over Wifi or Ethernet? Are you using any switches in this setup? Is the QNAP and the Pixel and Pixelbook on the same subnet as the Core and not on a “guest” network of sorts? Have you tried rebooting all of your network gear, including Router, Switches, Core and affected Pixel and Pixel book devices?

Please let me know your findings when possible.


The QNAP is connected to the orbi through a NETGEAR GS108NA ProSafe 8-Port
Gigabit Ethernet Desktop Switch. The Pixel 2 XL and Pixelbook are both on
wifi on the same subnet as the core. My Windows PC is also connected via
wifi and can connect to the core without issue

Rebooting the devices has no impact. If I reboot the router I can connect,
but if I close the app it will not reconnect. Restarting the Qnap will
allow me to connect but if I close the app it won’t connect again

Try to disable IGMP snooping on the switch by connecting to the switch’s IP address with a browser and navigating to the Multicast tab:

1 Like

Thanks for the suggestion but this switch is unmanaged so there is not an admin page that I am aware of

Hello @John_Cale,

I consulted a few of my colleagues for the issue you are experiencing and they confirmed that because the Pixelbook is using a Sandbox Firewall, it is almost impossible for Roon to communicate properly with the Core.

You can read more regarding this issue in these links:

As you can see in those threads, some users have reported that connecting to Roon by fixed IP temporarily resolves this issue but the sandbox environment in general prevents a stable connection from reaching the Core through the firewall. I haven’t heard any updates regarding those threads but you may want to ask users who reported success as to what they changed in their setup to get it working. Hope this helps.


Thanks for the response. Does my Pixel 2 XL phone suffer from the same problem?


No, Android devices should be fine – I use my Pixel 2 XL on a daily basis.

@noris was only referring to ChromeOS, which can run Android apps but which has some firewall restrictions that prevent Roon Remote from finding your Core.

No android devices can connect on my network. I have the pixel 3 now and it is the same thing. If I reboot the qnap or the phone it will connect but will fail the next time I try.

Hello @John_Cale,

If other non-android remotes do connect successfully, something in your environment or network might be triggering the issues described in this thread, which unfortunately we are still not able to reproduce in house. We are working on re-building our Android infrastructure and hope to improve this behavior in a future update, but in the meantime, I have also tagged @crieke in case he has some further suggestions here.


Hi @noris

I tested using a different router and it seems to resolve the issue. Not sure if it is an issue with all mesh routers but the Orbi seems to be causing the problem.


If Orbi allows it, try to turn off IGMP snooping, it might help (it does with other gear).

Unfortunately Orbi has no IGMP snooping setting

Hello @John_Cale,

What firmware version are you using for your Orbi setup? I have found this article that states that IGMP Snooping/Proxying has been added only with FW version

Can you please verify this?


Hi @noris, I am using the most current firmware V2.2.1.210. I have also switched the Orbi to ap mode and still experience the issue.

Hello @John_Cale,

We have seen the IGMP Proxying setting resolve issues similar to yours:

Other than checking this setting you would also want to make sure that the Orbi is using the same subnet as your android device: