Cant connect to Roon Core


I cannot get RoPieee to connect to Roon Core I had it connected once but now I cant get roon to see it I have the DAC (SMSL M400) pluged in and set to USB the DAC says USB connected I can get to the RoPieee web interface on the network from the PC that roon core is on so I know the network connection is OK I have sent feedback the file is 41cae58e16a57da7

If I click on About (Roon Core) I can see RoPieee under Roon Bridge but nothing in audio

Just to add in Roon I can see other roon devices on the network my chromecast TV and iPad which is running Roon Remote so roon seems OK

Any ideas?


Hi Jed,

Thanks for sending the feedback.

The reason the device does not show up in Roon is because something goes wrong while the DAC is being set up. There are some errors on USB level, regarding in the end the device is being disconnected.

Hence no device, which results in not showing up in Roon.

I’m not particularly hopeful if it helps, but could you switch to the beta channel (you can find that option on the ‘advanced’ tab)? In beta is an update on the kernel which might improve on this area.

Let me know how it goes.


I will try it now


One more thing:

  • can you also try a different USB port? The Pi 4 has next to USB 3 also USB 2 ports. I suggest you make sure it’s plugged into one of the USB 2 ports.
  • does the DAC has a potential firmware update available?


@spockfish The beta seems to have resolved the issue I have it plugged into USB3 USB2 also seems to work

Thanks for the help

Good to hear!

Thanks and enjoy.

Hello @spockfish,

I’m experiencing the same problem, but have not connected a DAC to my raspberry pi yet. I switched to beta in the advanced tab as you suggested.

My raspberry pi still can be seen in the Roon app in the About section under Roon Bridge but not in Audio.

The log number is a7e5115cf5003c3f.


I believe you need to connect a DAC for it to show up as an audio zone, do you have one to try?
What you are reporting so far sounds correct but it needs to see a DAC connected to then show up as an audio zone to be enabled.

That was what I needed to do! Thanks so much.

Any recommendations for a good Raspberry Pi hat? I’ve heard that some can enhance the sound through coaxial or BNC outputs. My DAC/amp is a FiiO K9 Pro. I’m not interested in buying a DAC/hat.



Having issue with Endpoint not showing up under Audio as endpoint. I am running latest version of Roon core and see the RoPiee Roon Bridge is showing up under About, but no endpoiint in Audio. USing SMSL m3 DAC connected to RPi 4B via USB. Tried multiple USB ports. Sent diagnostic via web page.

Log Feedback ID: 9e25309270a0ad1e


I don’t see your DAC at all in the logs. Have you turned it on? Can you try a different cable?

Yup, faulty cable. Tried a shorter one a it showed up in the Audio endpoint list. Thanks for the quick reply.

1 Like