Can't find a way to configure port forwarding on ATT Fiber Humax BGW320-500 router

Roon Core Machine

Intel NUC i7, wired connection to router

Networking Gear & Setup Details

  1. Who is your internet service provider?
    ATT Fiber

  2. Please list the make and model of your modem and router?
    Humax BGW320-500

  3. Do you have any additional network hardware, like additional routers or managed switches?
    2 Netgear switches between router and ROCK

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Auralic Aries Via WiFi connection to downstream secondary AP
Anthem Receiver via ethernet
Roon Remote on iPad

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Auto configuration is not working with this router. In the router configuration pages, I can’t find any reference to “port forwarding”. The closest thing I see is in the firewall section, a NAT/Gaming category, but this is looking for application hosting entries and I don’t see anything about UPNP or NAT-PMP.

Hi Sami,

Take a look at this youtube video. I hope this will help.

Kind regards,


That did the trick!

Thanks Maarten.

Hi Sami,

Good to hear everything is working now.

Enjoy the music at home and on the go.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.