Can't flash image to USB flash drive

After successfully installing Roon Rock on an Intel 8i5BEH I got an “Database and Network error” last week. I bought a new SSD 250GB Samsung EVO 970 and thought that would solve the problem.
The NUC recognizes the new SSD and I thought I was going to be fine.

When I download the flash image to the USB flash drive and I have tried both Rufus and Etcher, it shows that I successfully flashed the image. Right after that the USB flash drive disappears from the PC and I can’t see what’s on it. When I plug it in to the NUC, press F10 and select the USB flash drive it shows “Reboot and select a proper boot device or insert boot media in selected boot device and press a key”. I have tried four different USB flash drives and the same thing happens with all of them.

When I plug them in my PC afterwards, it doesn’t show up on the PC.

Help would be much appreciated.

Best regards,

As to your original problem, even 128GB for the ROCK OS is more than enough, 250GB is

Doesn’t solve your new problem, but if you still have the old M.2 for ROCK OS, reinstall it. You have problems elsewhere that is causing the database and network error.

ROCK does some Linux formatting that Windows can’t deal with.

I think the new ROCK version requires a UEFI boot.

The previous version needed a legacy boot.

So you may need to change your bios setting.


Changing BIOS to UEFI boot solved it for me.

Thank you so much Greg!


Perfect - glad that worked!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.