Can't get Nucleus configured to run ARC

Roon Core Machine

Nucleus v1
Server software Version 2.0 (build 1182) production

Networking Gear & Setup Details

A three node Deco M5 mesh network
An ethernet wire connects the Nucleus to the node that is designated as the router.
The router node is connected to my broadband service through a Technicolor TG589vac router that is serving only as the modem,

Connected Audio Devices

I am trying to connect an iPhone XR through the Roon ARC app

Number of Tracks in Library


Description of Issue

I got a message saying that the core is not configured to accept the ARC connection.
I’ve connected to the core from a Macbook run the Troubleshooting test. The message I get is listed at the end of this message.

I know almost about networking so some simply-worded instructions would help.
I have the Deco App installed on my iPhone and in there I can see that UPNP and
SIP ALG are enabled. I see that the app provides a way to set up a port forwarding rule. Beyond that I am clueless.

Thanks very much for your help!

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“fe80::AAAA:BBBB:CCCC:DDDD:fe34”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

This could be an issue with your carrier (CGNAT - carrier grade NAT). Any chance to ask them have a fixed public IP address assigned to you?

Welcome to the Roon community, @Alan_Frisch.

As @Bernd_Kurte, suggests, there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I have to comment on that because “fixed” is written much to often. A fixed one is ideal for ARC but difficult to get from most ISPs. A consumer customer asking for that will nearly always get a “no” from the ISP.

A dynamic public IP is generally fine though, as long as it’s a real, routable one (not CG-NAT)

1 Like

We can agree. Although it took me only one friendly phone call with vodafone here in Germany. But YMMV

Either dynamic or static IPV4 address is needed if CGNAT is the default offer from an ISP.

Incidentally, I have a dynamic address albeit it hasn’t changed in many months.

Indeed :slight_smile: Just saying that not being able to obtain a fixed one is not the end of the world

1 Like

Thanks everyone for your prompt advice, some (but not all) or which I understand.

I believe that I long ago set my ISP-provided router to bridge mode, but I will confirm that.

I thought that enabling ARC would be easy so gave it a go while I had a bit of free time. Now that I see that this is more involved, I will not be able to get back to it immediately. When I do, I’ll do my best to follow up on this advice, but almost certainly will wind up needing more advice.

Thanks again and happy holidays!

Hi @Alan_Frisch,

I hope you’ve had a restful and relaxing holiday season and New Year. If you’ve had another chance to try configuring port forwarding manually, the team is here to support.

1 Like

This topic was automatically closed after 173 days. New replies are no longer allowed.