Can't get Roon ARC to connect despite setting manual port forwarding on CenturyLink C2100T

Roon Core Machine

Apple iMac 2015 i7 with 32GB ram, running Monterey 12.6

Networking Gear & Setup Details

CenturyLink C2100T on WiFi

  1. Who is your internet service provider?
    CenturyLink
  2. Please list the make and model of your modem and router?
    C2100T
  3. Do you have any additional network hardware, like additional routers or managed switches?
    No
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No

Connected Audio Devices

Holo May DAC (USB)
RME ADI 2 (USB)
Apple TVs (Airplay)
Sonos

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
Says Roon ARC “not ready” and that Roon ARC was unable to securely access my Roon Core.

Uh, despite going into my CenturyLink settings and setting up port forwarding with the Roon Core IP and Port identified in CenturyLink, nothing’s connecting. Attached is screenshots of what was setup in CenturyLink. I should add, I have to port forwarding rules, one for Plex, the other newly created for Roon ARC. Plex is working fine, but Roon ARC isn’t.


You need to remove the remote defined IP address. Currently the way you have it setup only your Core can access itself!

Ah, got it.

What should the configuration range be, then? I guess I understand what your saying shouldn’t be there, not sure as a layperson I get what should be set up as the right “rule”, if you will.

The LAN start and end ports define the ports to use internally to your core. As start you can set 55000 and as end 55002 as these are the ports often used by Roon Arc. You can check this in the settings of you Roon Core on the Roon Arc tab.
The external IP address you can leave empty. This is used to limit the access to a specific external computer but this is seldom used.
This is the same way you set up the Plex forwarding.

Ok, thanks. My sense is this is extremely basic stuff but thanks for the clear explanation. I set up my Plex forwarding but only with similar directions from them, so the level of detail is appreciated. I’m not tech-ignorant like my Grandma, but I don’t deal with setting up routers and doing port forwarding except once in a blue moon, so it’s not naturally intuitive.

Anyway, thanks again. I’ll make the adjustments later today and respond here that either I’m up and running, or convey if I’m still having problems. Stay tuned.

You’re welcome. Hope you get this solved. Don’t hesitate to come back here if it doesn’t work.

@Charles_Wynn,

Firstly, it looks like you might have a Plex server configured for external access as well. If so, is it working correctly or using Plex’s relay capabilities?

Second, you have a C2100T modem which is “near obsolete” for CenturyLink. I had one and they refused to give me technical support for a configuration issue. Rather than buy or rent a newer modem from CL, which they insisted on before they’d help me further, you can get second hand ones from Re-PC in SoDo in Seattle.

FYI, I told them I was cancelling my service and I got a speed upgrade to 200mbps both ways, a new modem (C4000XG), and my bill cut by $70. The C4000XG is about $40 used at Re-PC. Cheers!

1 Like

Well, I’m back because it didn’t work, lol!

I made the changes with a port forwarding range, but still have the same problem where Roon ARC not working. Latest screenshots below. I admit to being disappointed/frustrated because I thought we had a solution! Any next step troubleshooting?


Screen Shot 2022-10-17 at 9.14.53 AM

Oh wow, GREAT feedback, thanks!

Plex is setup and working great for external access, for about the last two years.

This is an old router. We’ve been in our home for 8 years, and I think this is the only router we’ve ever had. But the fact that the Plex port forwarding is working flawlessly with it does leave me wondering why I’m having challenges getting Roon ARC to work. But forcing/getting CenturyLink to provide an updated router is an option too.

I see no error message on the Roon Arc image. Did you delete it? If not, you might restart your Roon Core and see what it shows there.

Yeah, not sure what’s going on that I’m not seeing the Roon Core IP anymore, but I surely have the error message that Roon ARC isn’t working. See attached.

And I have closed and restarted Roon a couple of times already, to “clean the pipes” if you will. Still no change.

The thing I don’t understand: there is nothing displayed in the box ‘Diagnostics data…’
Perhaps @support @connor can help us further

1 Like

Hmmm. Here’s the working configuration from my C4000XG:


The first entry is Roon (duh) and the next two are Plex servers. Perhaps you could try defining just a single port rather than a range to open. I’d suggest reverting the port number to 55000 in the Roon ARC UI and in the C2100T Port Forwarding UI.

Once you’ve done that, try https://canyouseeme.org to confirm that the port is actually open.

Thanks Brian. I had actually done that, but direction from Roon Support here was that a “range” is the recommended methodology. I’m left confused with it all at this point.

Yes, such additional Roon Support help would be greatly appreciated. I have the same question, which is a head scratcher. Not only for the diagnostics data issue, but the fact there’s nothing showing for the Roon Core IP, when the day before there was. Weird all around.

Hey @Charles_Wynn,

Thanks for the information. After enabling diagnostics on your account, we’ve found that there looks to be a second router appearing in your mobile diagnostics. Do you have an Eero router in your network setup?

With that, we’ll also need clarity on the manufacturer of your gateway router (from CenturyLink) and if there is any additional network hardware connected to it via ethernet.

In addition to this, we saw that you may be using the wrong ethernet port. We see the IP address listed for your core (192.168.x.xx) is on port en2, while the IP address listed in your roon core IP is not the same. The IP you’ve put in the rule may be on a different subnet than the static local IP address of your core. I would double-check this and make sure you’ve made sure to input the correct core IP :+1:

We’re on standby for your reply

Hi, sorry for the slow response. Been a busy wave of work that kept me preoccupied. Following up with responses:

Yes, I do have an Eero router in my setup. The manufacturer of my router from CenturyLink is their C2100T model. I’ve come to understand this is an older router, been in our house since when we built the house seven years ago. It IS working fine with Plex for port forwarding though. I’ll recheck the “mismatch” of IP addresses, which is entirely possible that it’s user error there, as I’m not super technical but would assume I can handle troubleshooting this to get Roon ARC working. At least that’s the hope, with your support!

Best,
Charles

1 Like

Hi Roon ARC team,

Respectfully, what’s going on here? Is anyone from Roon looking to follow-up and provide troubleshooting support leading to a solution here, or have I been abandoned? It’s been a full SEVEN DAYS since ANY response to my last message, I answered the questions asked of me (yes I have an Eero network), and more importantly, no one responded to the weird behavior that was happening with my Roon Core IP not showing. I really was hoping to get this resolved!

I’ve attached an updated screenshot of what’s showing in my Roon ARC settings as of today. This thread has multiple screenshots of my Router configuration. Please, what is the next steps to solve for this??

I apologize for my frustration, but I really did expect a bit more support help, and as a Roon lover with a lifetime subscription, I’m still interested in transitioning from using Plexamp to unifying all of my listening through Roon.

Thanks in advance,
Charles

Hey @Charles_Wynn,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

What were your findings on this?

We’ll need more details about this second router and how it plays into your setup. Most likely, you’ll need to set the Eero router to bridge mode, we’d be happy to help but will need again the specific model number to move forward with that. I am assuming the Eero router is feeding into your Century link router? For general instructions on setting your Eero to bridge mode:

  1. Open the eero app and tap Settings (bottom right corner)
  2. Tap Advanced.
  3. Tap DHCP & NAT.
  4. Switch your selection from Automatic (recommended) to Bridge or Manual (for those running static IP)
  5. Tap the Save button in the top right corner.

If your CenturyLink router has port forwarding properly configured, you should be good to go after this.

I would triple-check to make sure Plex isn’t using the same port or range of ports reserved on the router. Their infrastructure is built a bit differently than Roon, and so just because one works unfortunately will not indicate whether the other will work out of the gate.

I’ll be monitoring this thread for your reply :pray:

1 Like