Can't get the Squeezebox connected

Well for me it worked once but never did again since. I see my
squeezebox in windows network (didn’t see it until i turned usb sharing
on SBT). Still no go Roon doesn’t see the device. Tried reset factory,
updated SBT to 7.8.0r16754 disconnected squeezebox several time restarted computer.
Resarted Roon no go. My LMS is off also. Tried SBT wireless and connected no success

What I am missing?

On the SBT display, if you select “My Music” what music server is it saying it is connected to?


In 'My Music" it just shows all my music I connected using remote librairies and typing the ip of my computer and i see all my music

On the SBT display, when you select my music, the name of what you are connected to should show up at the top. For me I have Roon on a NUC called WINSERVER and this is what shows up on the Touch display. Once when I was having issues I had to “switch library” on the touch display to move it to WINSERVER.

I think if you can navigate music on your Touch display that you have LMS running somewhere (on a NAS?) as I only ever get an option to switch library when I choose my music on the Touch display when it’s connected to Roon.

I hope this makes sense, I’m not in front of the system at the moment.


Thank for the help! You might be onto something here, I had LMS starting automatically and was closing it before using Roon. I disabled it in my startup and whatever I do I always see my library! Even after factory reset. To answer your question in 'my music" it shows on top the name of my computer. I guess it is because i used ‘connect to remote librairies’. I tried going on Radio on SBT and when I come back on my music it reconnects automatically on my server

LMS is not on a NAS if that can help you help me

I’ve taken a few pictures of my touch screen.

These are my only options when Roon is set up properly.
Selecting my music shows

If I choose to switch library I have nothing to switch to which is correct as only Roon is enabled.

I hope this helps.

By the way you do have squeezebox beta enabled in Roon


Yes it is activated. Thanks again for the info. I have all standard options on the SBT not a screen like yours

Do you see TEMPO-PC where I see WINSERVER?

If you’re not it seems to indicate LMS is still running somewhere.

And that’s about the sum of my knowledge!


thanks for your time I will try uninstalling lms altogether to see what happens.

IT WORKS!!! Yippee I like way better using Roon to LMS anyway! Thanks mister you got me on the right path right away mentionning LMS was the problem

1 Like

Glad it worked for you, enjoy the music.