Can't Log In To Raspberry Pi 4 Running RoPieeeXL

I have two RPi4 running RoPieeeXL and both work perfectly. One is connected by ethernet and one is connected by WIFI.

I just updated the RoPieeeXL software on the RPi4 that is connected by ethernet, but can no longer log into the one that is connected by WIFI. I think it is being blocked by my Windows firewall, but even if I turn that off and disable the firewall, I can’t get in. The address is showing on my router as an active WIFI address of but I get a message to check the proxy and the firewall.

Please help with this so I can update the RoPieeeXL software. Thanks. It is still found by Roon, playing music, and the screen is working, all using WIFI. I am obviously not knowledgable about such matters.

If you can connect to one web UI go tot he devices tab and try clicking the link to the second one and see what happens.

if that does not work try rebooting the one on WiFi and try again.

Thanks. It shows up but does nothing when clicking on it. I’ve rebooted numerous times. It also does not connect when plugged into ethernet yet is still works with Roon. I even tried another download of RoPieeeXL and reflashed a different micro USB card. It almost seems like a hardware problem on that particular Pi4. I may try swapping the micro USB cards between the two Pi’s next if nobody has a better idea.

On second thought, I think I will not swap the micro SD cards. I don’t want to mess up the Pi that is totally working AND able to connect. The second one still works, I just can’t update the software since I cannot access it via the browser.

what browser are you using? can you try a different one?

I use Google Chrome but also tried Microsoft Edge with same result. Since it works using Roon and Dragonfly Cobalt over WIFI, I guess I’ll just leave it on the version of RoPieeeXL it is on and not worry about it. Something has changed somewhere and I can’t figure it out. But, thanks.

@spockfish Any ideas?

So, I took the Pi out of the case and reflashed (again) and got it working and was able to get it connected with WIFI. This was without the screen. So, now I am reflashing for the third time and will put the Pi back in the case, with the screen, and should be able to get it going. I’ll know soon.

OK, it’s working now. After reflashing three times and getting WIFI working without the screen, I reflashed again and reassembled in the case with the screen. Once I got it going I could not get the display to work. Then, I realized I needed to reactivate the Roon extension AGAIN. So, anyway, it’s all good now.

1 Like