Can't log in to Tidal

Yep, same here, dropped my connection to Tidal while listening to a non-Tidal file in Roon. Can log in to the website and the iOS app just fine. I quit and restarted Roon and now I appear to be back in. Hmmmm…

Quit and restart doesn’t solve it for me…anyone any ideas?

Hey @Peter_Myers – can you try this:

[quote=“mike, post:7, topic:1157”]
if you’re having trouble logging into TIDAL when using Roon on OSX, you may want to start by deleting the cache [/quote]

You can find the cache folder in your Roon directory. Once you’ve deleted the cache folder, restart Roon and try logging in again. Let us know how it goes.

I’m experiencing the same problem with Tidal login, but from an iPad mini. I can log on to Tidal fine from my laptop, in fact I can log on fine from the Tidal app on my iPad…just not from the Roon app.

FYI, the iPad is running Roon remote, with Roon server running on a Mac Mini. The Mac Mini is wired to my router via ethernet cable, and can access the internet fine for other things.

Re-installed Roon and now it’s working. Hopefully this won’t become a recurring issue.

Still having problems logging into Tidal on OS X … the Tidal account details are fine as I’m able to log into the Tidal website without issue, and I’ve removed the cache and then re-installed Roon as per the suggestions above, with restarts in between. But I’m still getting the “an unexpected error occurred” dialog on the settings page. Any ideas?

Would you mind to share Roon logs with us? I’ll contact you shortly via PM with the instructions.


I ran into the same problem today. When I went into settings I noticed that the Tidal sync hadn’t happened since June 1st. When I tried to run the sync it wouldn’t work.

I logged out of Tidal in Roon, and tried to log back in and received the “unexpected error”, and was unable to log back in.

Double-checked my password using the Tidal website and it was working there.

I reset my password on Tidal.

Closed the Roon Core app on my Mac and re-opened it, and was able to sign into Tidal again through Roon.

The last four days of album additions was gone, but everything seems to be working again now otherwise.

Not sure if that’s helpful or not, but thought I would share just in case there is an emerging pattern.

Same problem. Deleting the cache does not work. Just happened from one day to the other, with no clear reason. Tried to reset password. Tidal access online works fine, as well as with Tidal OS X app. Quite frustrating !

i’m having this problem this morning. i can log in, but most albums won’t load.

update: deleted cache, restarted roonserver, all seems fine now.

Hi @Pierre_Kalitventzeff — Just checking in to see if you’ve had any change in your result, thanks!

7 posts were split to a new topic: Problems with a New Roon Installation

A post was merged into an existing topic: Problems with a New Roon Installation

A post was merged into an existing topic: Problems with a New Roon Installation