Can't mount Apple Music library from Mac Share to Nucleus+

I’m getting “Unauthorized” when I try to mount a Share with my Apple Music library I get “Unauthorized” error.

I have read the more generic posts, have have done the following:

  • I was able to mount a different Share with the playlist exports from the Apple Music library using an administrator’s UID and password
  • I set up both shares with read/write access for Administrators and the UID/Password used
  • I have been able to use IP and username, but once I go back to the Storage directory, all of the folders are listed by IP
  • If I remove the UID/Password, I get a more generic “UnexpectedError”
  • Note: The folder in question is on a different disk than Playlists, but the MacOS should be hiding that information from any remote system attempting to mount a share

What’s left to try?

Lee, can you provide any screenshots of what you are seeing, your network share, your Roon library path(s) and any other information? Is the Apple Music library on a Mac, a USB drive, or a NAS? Have you been able to configure a Mac folder share previously? It seems the playlist directories may be mounted but want to make sure.

Share setting on my Mac (fixes are up-to-date):
Note: The Playlists share has the same settings

Settings on the Roon Nucleus+ (also current on fixes):

And driving down into Playlists (the one that worked):

Here’s the failure attempting to mount the AppleLossless share:

I don’t know how much configuration of the folders on the Mac influences this failure, but I’m willing to dig deeper, if guidance can be provided. But the salient point is that the Mac allowed the share.

It’s worth noting that I’ve tried every variation I can think of. For example:

The ones that don’t get “Unauthorized” get “UnexpectedError”. There are very few options that seem to be close to correct.

Is the folder containing your own files purchased or is this Apple Musics downloaded hires versions of previous purchases Or Apple Music offline playback? You cannot access that if so as it’s protected and can only be played accessed via Apple Music.

1 Like

All ripped albums.

Forgot to mention, when I was running a Roon core on my Mac, it had no trouble accessing the ripped albums in my Apple Music library.

Roon Core Machine

Nucleus+, Roon version 1.8 (build 1021) stable
Apple Library on Mac mini (2018), 3.2 Ghz 6-core i7, 64GB DDR4 RAM, macOS 12.5.1 (up-to-date)

Networking Gear & Setup Details

AT&T 1GB fiber connected
Araknis 310 Router: AN-310-SW-R-24-POE
Araknis 110 Switch: AN-110-SW-R-8
Araknis 310 Switch: AN-310-RT-4L2W

Connected Audio Devices

2 Naim Atoms
1 Mark Levinson 5101 Streamer
Not yet enabled, Mac Mini, Macbook Pro, 2 AppleTVs, 2 iPhones, Nucleus ports

Number of Tracks in Library

Currently, 15,000 on a Naim Uniti Core
Need to connect, 16,000 in Apple Library (all ripped albums)
Also connected to Tidal

Description of Issue

The Nucleus has not been able to mount the Share with the Apple music library.
It has been able to mount a share with the exported playlists, but they aren’t loading (assuming that’s because nothing referenced in the XML is accessible)
Created a community post with more detail, including answers to questions from other users,

Additional comments:

  • Nucleus does not see Mac Mini as a potential Root Audio device
  • When my core was on the Mac Mini there were no access issues, but I had to reboot the system regularly (overworked)

Lee, it’s best to keep all the posts for the same issue together. I moved your recent post to here for consistency.

Looking at how your are setting up your SMB mount to the Mac, I see in your screenshot that you are using the IP address and then referencing directly the AppleLossless directory. Is this directory in your root directory of the Mac? Otherwise, you may need to reference it per this from the Roon knowledgebase:

I’ve seen others forget to add the User path where the folder sits, and want to make sure that is or is not the case for you here.

Is there any known issue with putting the data on a different disk (as in this case)?

I’ll try rebuilding the share with explicit path (if macOS allows it).

None that I am aware of. I also was going to recommend possibly placing your Apple music on a separate USB drive attached directly to the Nucleus Plus.

If I unmount the disk with the Apple library, does the Nucleus copy the content, or do I need to leave the disk attached to the Nucleus?

Related question: Can I backup to an attached disk?

So, simplest solution is to copy the library to a separate disk and attach it to the nucleus, then repeat when I make updates to the Apple Music library?

That I can test.

Related: macOS only lets me navigate to a folder when setting up a share, so I’m out of ideas for the Share.

Lee, yes, you can backup to the external drive if it is formatted to a format supported for Read/Write privileges by the Nucleus. I recommend NTFS but Macs only can read these, and cannot write to them unless you have a driver such as NTFS for Mac (which is what I use). Safest bet may be to use ExFAT if that is the route you select. Safest bet would be to backup there and then copy the backups again to another drive for safekeeping.

And copying the files, even in the directory structure from the Mac, should work on the new drive and with the Nucleus. When I move my files from my Mac to my Windows Core, I use the exact same directory structure and Roon works fine, You will need to set up the new location within your Core identifying the new attached drive and the folder(s).

Thank you for your assistance:

  • The copy of the Apple Music library is attached and indexed
  • The exported playlists (on the same disk) imported automatically and successfully
  • The separate backup disk is functioning correctly
  • I configured an HDMI port as output to a soundbar and the sound is noticeably better then the fiber connection from the Mac (through the TV)

You may close the ticket

Great to hear everything is working again for you Lee, enjoy the music!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.