Can't see the Server via Roon Arc even in the same network

Roon Server Machine

iMac 27" 2015

Networking Gear & Setup Details

I’m on Fastweb Gigabit Fiber, no VPN, no custom DNS, NAT + DHCP plus Eero Mesh devices. The Server is connected via Wifi and can play from streaming services added to Roon fine.
First I had no port forwaring an Eero was also in NAT mode, that gave me an error message saying double NAT found. I set Eero to Bridge mode and can confirm now that I’m getting IP addresses via DHCP from the Router.

Then I added the port forwarding rule as recommended:

While I got different error messages during this process,
the current state is that I can’t see the server even from within the same network.

The error message is:

“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2001:kkk:lll:mmm:nnn:ooo:ppp:qqq”,“router_external_ip”:“100.hhh.iii.jjj”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Why is it still MultipleNatFound?

I read elsewhere that one solution would be to ask Fastweb for a static IP address, but I am only one user of the network, and strictly speaking not the admin.
Can I solve this via VPN or other ways that I can set up more permanently?



If you have elliminated all reasons for the double NAT within your home network as it appears you have, then the remaining cause is that your ISP is currently using CG-NAT (Carrier Grade Network Address Translation) to issue you with a WAN side ip address. Some ISP’s use CG-NAT to allow their limited supply of ipv4 addresses serve a larger number of customers than would otherwise be possible.

This being the case, it is beyond your ability to solve it on the local network - the port 55000 traffic will not even reach your network - so you need to contact your ISP and get them to provide a solution.

The solutions that the ISP can offer may be a static ipv4 address but not necessarily so. They may also have a pool of Non-CG-NAT ip addresses, one of which they can allocate to yourself in which case, you would still have a dynamic WAN side ip address.


Wade is right, this is for sure a CG-NAT problem. See the log, the router external IPv4 starts with 100.hhh.iii.jjj. That is most likely your ISPs pool of adresses used in their CG deployment. And there is your doble NAT, actually down from a tripple NAT, before bridging the ISPs router. Call your ISP, they might have a solution.

1 Like

Thank you so much for the quick response!

I am just a user, not really the admin of the network, but if I can set this up in a way that the ISP gives me a static IP and I just do NAT over the Eero devices and the router is bridged, it should not affect anyone else… so I’ll try that :blush:

Until you have talked to your ISP, don’t do anyhting else on your home network.

As it stands at present, it looks as if your home network is correctly set up with all devices on your home network having a 192.168.1.x ip address.

This being the case. all you need is a non-NAT WAN side ip address to replace the 100.x.y.z ip address that your ISP has currently given you.

1 Like

Will try to talk to the provider today, thanks again! Didn’t know about Carrier grade NAT or DMZ before any of this :slight_smile:

Do not use a DMZ. This will not solve your problem and opens up your network to a whole host of vulnerabilities.

A DMZ opens all ports and forwards them to the nominated device. A forwarding rule (or uPnP) only opens the required port(s) and forwards them to the nominated device.

1 Like

Hi @Wagninger,

To echo @Wade_Oram, do not simply expose your RoonServer machine by putting it in the router’s DMZ. Were you able to identify whether a dedicated external IP was available through your internet provider?

It seems to be available, but the support process is very tedious… until now, support says they gave me a static IP address, but the router settings have not changed and they didn’t tell me which IP address I now have… another round of support at some point to find that out

It is likely that, although they have given you a static Ip, it is still configured using DHCP.

If this is the case, the the router settings do not have to change and you can tell what your IP address is by looking at your WAN side ipaddress reported by your reouter or, if you have to, visiting :

If you have a static ip address, and you have ellimated the use of multiple subnets (which you appear to have), then the only thing left to do is to configure port forwarding by either enabling uPnP support or creating an explicit port forwarding rule.

In your original post, you had uPnP enabled, and it appeared to have configured a port forwarding rule.

Have you tried re-starting you router and Roon Server since you were told you have a static ip address?

If you do this, and still have a problem, post the updated error text from Roon->Settings->ARC.

1 Like

that was really the case, I seem to have a static IP now! Will get straight to setting things up then :slight_smile:

Ah well … the router is reporting a 100.x wan address that I can’t change, but whatsmyip now reports a 93.x.

I think what I would have to do is put the router in bridge mode, but I am not the network admin (father in law is, and I don’t want to stress him too much about a topic he doesn’t care about)

No. the 100.x.y.z router WAN side ip address is possibly still the CG-NAT issued ip address - particularly if the x part is between 64 and 127 (ip addresses in the to are reserved for the iSP’s use of CG-NAT) and the other ip address that whatsmyip reports (93.x.y.z) is the ip address on the internet side of your ISP’s CG-NAT solution.

You said:

What makes you think you now have a static ip address? If you have not been sent details the static ip address to use, and the router is still picking up a 100.x.y.x ip address, even after a reboot, then it appears that you have not yet got a static ip address.

If you have any communication from your ISP with the static ip address that has been assigned to them, then you should be able to set the WAN side settings of your router to use static ip address assignment and set the ip address that you have been given. Otherwise, you will have to wait on your ISP (or contact them again).

Their last communication was that they gave me a static ip and I have to change the router settings to make it work, but indeed didn’t tell me the ip, gateway or where to change what … ah well.

This would have been nice to have, not necessary - I’ll just give up on Roon Arc for now, since I am not the network admin, the network admin doesn’t care about this and we don’t speak the same language :sweat_smile: when I got my own internet connection and time, I’ll revisit this.

But thank you so much for the patience and knowledge!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.