Changed Router - Now Roon No Longer Sees My NAS - how to change the NAS address in Roon?

As the title says. Just need to know where, in Roon I change the NAS address to the new IP address based on the new router. Thanks.

We need a bit more info. Is your music storage on the NAS and you want to want to point the Core to this? That’s in Roon Settings > Storage (same place as you set up the NAS in the first place). You probably have an entry for the NAS storage with a three dot menu on the right. When you click this there should be an edit button.

See this as well:

If you have a decent router that provides a local name service, you could also use network names instead of IP addresses and avoid things like this when the IP address changes, as long as the router announces the devices under the same name

Yes, my music storage is on the NAS. I went to storage to correct things, as you recommended. I entered \\music, which should be correct, now. I get a Roon message saying “invalid path specified”?

On Windows, it must start with a double backslash. Maybe you did that and the forum just removed one of them from your post. (This happens because the backslash has a special meaning for the forum software. To make two appear, you must write three. So if you just typed two, one of them does not appear). I.e., like this

The next thing is, does your NAS really share the music as \\\music ? It is often something like \\\Multimedia\Music
Note that it probably is also case sensitive.

Of course if it worked like this before, justs with a different IP, one would assume that it still does.

Maybe the additional details here help?

1 Like

You are correct, the second backslash did somehow get removed. The address for the NAS that I shared is based directly off what the previous address, before the router changed shows as. So, I’m still at a loss?

I’m a bit at a loss now :cry:

Maybe a silly question, but are we sure that this IP is correct? Is the NAS running? Try opening a Windows File Explorer window and access it from there. If \\\music works from Windows, it should work from Roon. If that does not work either, something is probably wrong with the NAS, the IP, or the router setup.

(searching the forum)

Wait a minute. You asked the exact same question with the exact same IP in August. Here was an answer from that thread:

Could it be that is still the old IP from back then? Or did you never get it to work (the old thread ended there) and you are now making a new attempt?

Thanks for your help, and apologies for the frustration. I just checked and \\music takes me directly to the NAS in windows

OK that’s progress and rules out a bunch of possible causes at the side of NAS and network. Back to Roon then :slight_smile:

Except that I still have no clue what is going wrong in Roon then. As far as I can tell it should work.

Is your Roon Core installed on that same Windows machine or on another one? Or is the Core still the same Small Green Computer Sonic Transporter as in the old thread from August? If so, all I could think of is that somehow the router put the Sonic Transporter on a different subnet of your LAN than the Windows machine. If the NAS is on the same subnet as the Windows machine, Windows would find it but the Roon Core on the Sonic Transporter would not.

Please check on your router administration page what the IP addresses are of the three machines: the NAS, the Core (Sonic Transporter?), and the Windows machine.

I also moved this topic to #support because we need more visibility here for others

The core is still the same Sonic Transporter. I just verified that the address for that is

Thanks. So same subnet as the NAS, 192.168.50. I am now officially out of ideas. Paging @Wes as he was already involved in the old thread

Thank you! I And here I thought this was going to be a simple fix :frowning:

It should be! I don’t get it

If I can’t get some help with this soon, I’m afraid that I am unfortunately going to have to drop using Roon, much as I would prefer not to.

That would be cutting off your nose to spite your face just because you have some kind of config problem for a week. It happens. I wouldn’t be sitting at a computer if I had done that every time a computer didn’t work :wink:
Support will get to you, one after the other

Have you followed the steps given in this article on adding a Watched Folder to Roon where the folder is held on a NAS?

Can you post a screenshot of Roon’s “Add network share” screen, so that we can see the format of the network address that you are using? I.e. the screen like this:


The problem has been going on for a VERY long time. Many months, not just a week. But I do appreciate your assistance.

Here are two pictures of my screen that will hopefully explain things, and thanks for your assistance:



You appear to be trying to use a complete Network address (\\<NAS IP address>\<Folder name>) in the screen that is just asking for the name of the new folder.

Also, to post screenshots, rather than photos of screens, please use the technique described here:

When you edit the existing Watched folder, you first get the “Edit storage location” screen. Then you click the “Browse” button on that screen to get the “Choose music storage folder”

On this screen, you seem to be clicking the “New folder” button, but that’s not right. You need to click the “Add network share” link because you are defining a new network address, not a new folder to the existing network address.

I had forgotten about your older thread and was going by the start date of this one. It’s a long time and I understand the frustration, but I’m not sure how much of the problem is in Roon. I feel frustrated as well, doing this from afar, I feel like if I could get my hands on this thing it would be done quickly or at least I would understand where the problem is.