Changing sample rate conversion

1/i have my kef ls50 wireless speakers have no need for this DSD so i’m trying to switch it back
from PCM as per your directions…i was to switch back to default but got a warning
‘effects cannot be changed/undone’ or something like that…so was hesitant.

2/any good general default you’d suggest for filter: precise linear or other (this area still is confusing to me)…i can’t really tell the difference when i switch them around, however.

3/.i’m also getting occasional red clipping on the light (showing signal path)
it only shows red on the signal path light sometimes…but doesn’t affect the music playback

i use a very old laptop for visual interface on my separate music server (the sonic transporter i5)
so am unsure why this is happening

  1. Try disabling the DSP Engine entirely. Top left. That will remove all effects, taking you back to the source resolution. You can then add components as you choose.

If you get an error message doing this, can you screenshot it ?

  1. The settings shown are not upsampling PCM to DSD. Sample Rate Conversion is set to Compatability only, meaning conversion only occurs when the source is incompatible with your DAC. If you want to upsample in PCM, pick PCM here and DSD likewise. If you don’t have a DSD option then Roon hasn’t detected a DSD capability.

You can read some more about Sample Rate Conversion and distinctions between filters in this KB article.

If you are upsampling I’d suggest Smooth Minimal for Rock/Pop or other music with percussion (transients). You can experiment as you like though. The smooth variants have gentler frequency cutoffs and are shorter in time, the precise variants are steeper and longer.

  1. A red light means there is digital clipping. You can avoid this by allowing more headroom. Start with -3 dB and then -4, -5 etc until the red light stops. Are you using any PEQ ?

thanks…what is peq?

also i know about disabling the dsp top left…i do that plenty of times.
sorry i guess i didn’t convey my confusion…sorry…i’ll try again…is there a way
to start from fresh with settings for the overall device that would include dsp pcm etc.

PEQ is the Parametric Equaliser which is shown as enabled in the above shot, along with the Crossfeed tool. If you are applying some EQ with those tools then that might explain why you are seeing some clipping and limiting.

If you can disable the DSP Engine then you ought to be able to alter everything in it when it is disabled.

If you can describe the capabilities of your endpoint (the Kef LS50W ?) and what you would like to do then we can steer you through the settings.

I can’t see that the DAC in the LS50W has a DSD capability. The specifications refer to 192 kHz sampling rate.

thanks…but doesn’t dsp sampling help the music quality?
(and yes I do engage in slight EQ)
this is why i clicked it on these services (DSP).

If your using eq as well as upsampling then you need to probably adjust the headroom. By default it’s -3db but this is likely not enough. I had to reduce mine further when using peq to monorise one of my endpoints. Lower it a dB at a time until you don’t get clipping.

Oversampling increases the bandwidth of the signal, allowing gentler filters to be used.

thanks gang