Chunked M3U8 streams

Hello – Roon has Lithuanian National Radio with two stream links:
lower quality:
high quality:

A high-quality stream consists of ACC chunks, so Roon plays one of the chunks and then stops. Is there any way still to play this high-quality stream? On Sonos, this link works without any problems.

Hello @CODE1 , I’m afraid Roon is rather inconsistent with these HLS streams. Some work and others (like this) stop after the first chunk. I have never got to the bottom of which ones work and which ones don’t.

Furthermore, the testing link which the radio curators use to confirm if a stream is OK for adding to the database shows this stream as being without issues.

I have informed the Devs about these before.

(Interestingly, the stereo chunks are 9.984 secs long, but Roon stops halfway.)

Thank you very much. I hope this high-quality stream link will start to work, as I use it every day to gather the most important local news. I have a custom Roon system (Tivoli One + Baseus USB dac + Raspberry Pi4 with RoPieee, and Roon core runs on MacStudio), which is my primary connection to daily local news.

I just solved the problem: I moved my Roon server to the NUC Rock version, and a high-quality chunked stream started to work. So, just for your developers, this problem persists only on the Roon Server running on MacOS, so you should look for bugs in this server version. A dedicated server and hardware are better solutions, despite the ease of installation on MacOS (as it comes with the app, and there is nothing to do in addition).

Is this the same stream as you identified above?
I have a NUC and that stream stops after 5 secs.

Yes, and now it works perfectly. Maybe it’s because I have latest Rock version or I placed latest ffmpeg codec? But it definitely didn’t work on MacOs

Well I’ll be…

You are right! I updated my copy of ffmpeg on my NUC and the stream works. I wonder when that upgrade happened.

Thank you, Brian; we found the core of the issue. So, the problem is in MacOS codecs, not in the Roon Rock itself, as updated FFmpeg on NUC solved the issue. I also installed a new FFmpeg on MacStudio, and the problem persists. So, we have a solution from the user side - install Roon Rock or buy Nucleus. For people who want to use MacOS as a server, Roon developers still need to solve the issue with Roon installation (dmg file), which should include and install modern codecs to handle modern high bit rate chunked AAC streams. This message should be passed to Roon Devs.

For info, I tried Windows 11 - that worked.

I think it’s for licensing reasons that „On Windows/Mac, it uses the built-in system codecs“.


So this might be a macOS issue, as it seems to be working on Windows

1 Like

Roon Labs do not currently include patented codecs on any platform. So for MacOS and Windows, Roon relies on the codecs supplied in the operating system. Perhaps you should also ask Apple to update their codecs?

@support - does the link in the above article need to be updated to obtain the latest version of the ffmpeg codec for RoonOS?


I installed FFmpeg via Brew on MacOS, but that didn’t help. We need to know which particular codecs and how to update them. So then I could try that myself or write to Apple support. As for your question on the FFmpeg static library link, yes, it is correct, and you get the latest version from the main branch.
So, in the end, Roon Rock or Nucleus are the only fully working and flexible solutions for handling chunked AAc streams for the moment. The good thing with these options is that you can update FFmpeg with any version (lower or higher) at any time. This is fantastic flexibility and very easy to do.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.