Clicking on blank genre tile causes Roon remote to crash

Yesterday I turned the option to use my Genres back on to see if there were a bunch of genres with missing images. The issue was better than when 1.8 was first launched, but there will still a lot of Genres that were missing images even though they had an image when I clicked on them. I still cannot figure out why some genres show up as blank tiles even though they have images on their main pages while other genres use their images just fine. Any news on this from @support yet?
But moving on, Just now I imported some new albums and a new genre with a blank tile popped up on the genres page. I clicked on it and it caused my iMac remote to crash…Every time I tried to reopen it, it immediately crashes before it can fully start. I tried restarting everything including core, but it did not fix the issue. I now finally have Roon up and running again after completely wiping it from my Mac and installing it. This exact same thing happened when I first upgraded to 1.8.
After a couple of updates why did this have to happen again? I know things take a while but why has this not been fixed yet? It seems like an important bug to want to get fixed. So far I have a new list of about 10-15 genres that I cant use because they appear as blank tiles and will cause a crash. I was told last time this issue is being worked on so is there any information about this yet? I would like to be able to use my own genres but I still can’t.


Hey @AnimalOnDrums,

Thanks for bringing this up :pray:

To keep things unified, I’ve moved this post into your original one (this one) and reached out to our technical and QA team to see if there’s an update. We’ll make sure to let you know as soon as that is :nerd_face:

I am terribly sorry about the trouble :pensive:

A post was merged into an existing topic: Anyone else with missing Genre images? [Ticket In]

hey @beka ,

Thanks for the speedy reply and for merging my posts. I appreciate you looking into this.

Thanks again

1 Like

Hello @AnimalOnDrums ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Can you please confirm that this issue still occurs on the latest build of Roon? If so, can you please reproduce the issue and then use these instructions to send us a log set for review?

Thank you!

Hey @noris !
Hows it going? I hope you are doing well. So this actually happened to me yesterday as I was deleting the “Pop Rock” genre from all of the albums it showed up in. Here are the steps I took:
-I searched for “Pop Rock”
-In the search results there was a a tile for the genre “Pop Rock”. I was missing a generic image.
-I clicked the tile and went to the “Pop Rock” genre’s page, which listed all of my albums that were tagged with this genre.
-I went through all of those albums using an outside tagging application and removed the “Pop Rock” genre from the files.
-I then selected all of the albums that were shown on the “Pop Rock” genre’s page and re-scanned the albums. I missed a few but eventually the “Pop Rock” genre had no albums in it.
-From in the “Pop Rock” genre page I used the back arrow to go back to the search results page.
-The “Pop Rock” tile was still there after a minute, so I clicked on it to go back to the “Pop Rock” genre’s page. This caused Roon to suddenly crash/quit.
-I reopened Roon, which worked fine and made sure the “Pop Rock” genre page was gone, which it was.

This happened yesterday May 19th 2021, somewhere between Noon and 10pm my time. For some reason my NUC running ROCK is 7 hours ahead. Also, Is there a way to change this? Or is this normal and they all run on the same time regardless of the user’s location?

Here are the logs from yesterday up until I upgraded to 795. Dropbox - AnimalonDrums Roon - Simplify your life

Let me know if you have any trouble accessing them.

Hey @AnimalOnDrums — Just wanted to say thanks for the detailed reply and logs, and confirm that we’re looking into this. I’ve passed this all along to the QA team and we’ll be sure to follow up when we have more info.

Hey @dylan ,

Awesome! Thanks for letting me know, I appreciate it. :grin: