Clicking on Tidal "master" albums

I took the advice offered here and favorited several Tidal “master” albums so I could find and them through Roon. They have migrated to my albums list (wasn’t expecting that). When I click on a Tidal Master within my Roon, I get a loud clicking over the music. If I go to Tidal in the Roon menu and then find the album, it plays fine. Is there any way to prevent the clicking? And how do I remove Tidal albums from my Roon list of albums?


Favourites in Tidal are synced to Roon, which added them in to your library.

Similar adding a Tidal album in Roon, marks it as a favourite in Tidal.

The favourited MQA album, now in your lib is clicking.

The album you see in the Tidal section of Roon, will be a different version of that album… a non-MQA version.

So what you are getting is:

  • MQA version is clicking.
  • Non-MQA version is not clicking.

Are your network connections hardwired or via wifi?
If wifi or eithernet over power … try hardwired as a test.

Also try a different DAC if you have one.

In Roon … Tidal albums can be removed from your lib, by opening the album details page, clicking on the edit icon and then the delete icon.

I deleted the Tidal desktop app (which I had downloaded so I could find the MQA albums) and also deleted all myTidal favourites. Started over without the app on my Powerbook, and the clicking has stopped when I add favourites.

Thanks for your help.


If indeed you mean a PowerBook I think the latest PowerBook was discontinued in 1998…maybe you meant MacBook? And if it is indeed wifi then that might be the issue.

It is a MacBook. The problem turned out to be the Tidal desktop app I downloaded. It was causing the clicking. I deleted the app and everything is fine.



Is it fine because you are no longer playing a MQA file?

The clicking did come back. The solution was to run the output in exclusive mode. I’m given this option for my DAC.

My other output is a Devialet. The new Roon compatibility with Devialet handles MQA just fine. There’s no exclusive mode setting, so I’m leaving it in default.

The Roon-Devialet integration is exclusive by default – hence no setting. For DACs that are connected locally, exclusive mode is advised indeed.