Clicks and pops when listening. Very annoying!

New Pi4/Riopeee user. Using Roon Nucleus with the Pi4 and Riopeee. No Wifi, Wired. Sounds good but get annoying clicks and pops whether listening to Tidal or SSD drive. Any help?
Thanks in advance.

What DAC are you using and how is this connected to the RPi? Maybe share a screenshot of the device settings?

Do you get the clicks/pops during switch of track or continuously ?

Clicks and pops while playing. I bought a Nucleus, Sbooster power supply and a Raspberry pi4 with Ropieee. I can get the clicks and pops to go away if I turn on dsp. It sounds great but it completely locks up after about 30 minutes or so and I have to restart the Pi and the dac. My old Dell pc running Roon server connected directly via usb to my (Musical Paradise mp-d1 mk3) tube dac always runs great. I guess I’m selling all this stuff I just bought Bummer

Which Ethernet cables are you using? Are they unshielded Cat. 5e/6 ?
Which network switch are you using? Or are Nucleus and raspberry connected to the router?
Have you tried to connect the dac to the Nucleus?

Unshielded Cat5. Nucleus and raspberry both connected to the router. I bought the Nucleus intending to connect it directly to the dac but everyone here said it wasn’t intended to be connected directly to a dac. That’s why I got the raspberry. I tried the Nucleus connect to the dac via usb but I didn’t think it sounded as good as my Dell pc.

Could you try to use Cat5e or better Cat6 cables? Cat5 is limited to 100Mbps

I agree but it was just to try to identify the issue.

worth trying, but unless a cable is faulty, Cat5 at 100Mbps should be more than enough to stream even hi-res files.

I agree … mathematically … but Cat5 can bring issues, I myself had this issue albeit with a different setup

Does this happen with all tracks or is it dependent on the track resolution? Sometimes high res tracks can be difficult for networks and DACs and cause noise such as clicks or interrupts.

It’s random. No pattern.

What issues?

First, cool DAC.

Second, what DSP do you turn on to fix this? This sounds like a problem between the Pi and the DAC, since you have to reboot to fix it. When you connect the DAC directly to the Nucleus via USB, do you still get the pops and clicks?

Could it be the XMOS USB interface in the Musical Paradise mp-d1 mk3? Maybe upsampling everything may help?

Clicks and pops

That’s a symptom, not an issue.

I had the same problem. I chased it down to the Ethernet cable, either into or out of the RPi.

Can’t remember which it was because I now connect my DAC directly thru USB and haven’t looked back.

Do you have any suggestions ?

Sounds like a DAC issue to me. Is it well supported on Linux? Have you tried adjusting the buffer size as this can often help solve stuff like this. It’s in the advanced settings of the devices setup .