Cogent (ISP/Spain): I can't solve my multiple NAT problem and am running out of ideas

Roon Core Machine

Serial #94C691A8630F
Version 1.0 (build 227) stable
Roon Server Software Version 1.8 (build 1126) production1x
98% of 55 GB available.

Networking Gear & Setup Details

TP-Link AC3200 Archer router
Devolo magic 2 wireline adaptors
Synology NAS

So the NUC is plugged into a DEVOLO wireline device, which has 3 ethernet outlets, the head DEVOLO unit is plugged into the router/modem which is connected via a microwave link to my ISP.

  1. Who is your internet service provider?
    ISR communications
  2. Please list the make and model of your modem and router?
    Archer C3200
  3. Do you have any additional network hardware, like additional routers or managed switches?
    Yes, the house has 5 Devolo magic 2 wireline adaptors
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    All turned off while I am trying to fix this

Connected Audio Devices

RME DAC connected to an iMac
Naim Mu-So 2nd gen
Mola Mola Makua DAC/Preamp

Description of Issue -

ARC cannot access my roon core. The error message is below.

I have tried connecting the NUC directly to the router (i.e. bypassing the wireline devices). I still got the multiple NAT error.

I have paid my ISP to give me a fixed IP address. So I think only my router is making up IP addresses.

The error message below is after all this playing about. The 82.XXXX ip address is what my ISP has provided. The 192,xxxxx address has come from my router.

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

What can i try now?

You need Roon Server version 2.0 in order to use ARC… I don’t understand your setup as described.

The port forwarding diagnostics you’ve provided suggest that UPnP/NATPMP is partially enabled, but is not properly configured on your router. Moreover, you have multiple NAT and two private subnets. Is the AC3200 connected to a modem?

Ooops - sorry this was a cut an paste error. I definitely have Roon 2.0.

I did have trouble with roon down grading itself to 1.8 but this community helped me sort that out earlier this week. I now have 2.0 freshly downloaded, as to all the other devices.

Hmmmm yes.

The AC3200 is not connected to a modem. Well, sort of, it is connected to a microwave receiver that plugs into the “internet” port of my router. Is that a modem?

If there is another device on your network, please list it, and include make and model, as it is a possible cause of the double NAT.

Your external IP is public, and starts, yet the Archer is reporting It’s likely that this is the IP address of the other box.

You mean another device between my router and the ISP? The archer is plugged into a tiny box that has two connections: a co-ax cable from the 6" dish on the roof that points at my ISP, and an ethernet connection that runs to my router. Do you think that this could be the second NAT?

There are about 15 wired devices to my router, they all have addresses starting with 192… I thought that this number was coming from my router. I think that I have seen a set up page where this number is set. Do I misunderstand this?

Sorry if any of this is nonsense. The limit of my knowledge of networking has been exceeded.

Yes, this is likely. What is this device? Make and model details are needed.

Sorry for slow reply. I am going through a period when I am away from home a lot.

Here is a picture of the little box. It really does not look like the sort of thing that would have a NAT in it. Why put such a facility in a box with one output?

No serial numbers or manufacturers name. I think it is just part of the little 6" dish on the roof. That does have part numbers on it but is not easy to get to, so I am avoiding recording those details unless it becomes important.

No, this isn’t a network device. Does this component connect to a wall plate and the router?

And here is the error message that I get with the Roon NUC connect directly to my router…

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

By the looks og it i suspect this to be a PoE adapter.
PoE means power over ethernet.
These devices can power a compatible device in a place with no power available or to manage all from a specific place, like a data room.

PoE adapters have no networking functionality other than provide power.

This looks like you have two firewall/routers attached after each other, causing the double nat.
192.168.x.x subnets cannot be routet on the internet, they are used in private networks.

Draw a map of the (networking) devices at your premisses to provide a overview how they all are connected.
Do provide type information.
If you have configuration screenshots, that can be helpfull to.

Yes, the POE is powering my mini dish.

Honestly, I am not missing anything. There is no second router. My “map” would be:

The intel NUC, home to roon rock — plugged via cat 6 cable to my archer router C3200 — the router’s WAN port is plugged into a cat 6 cable that runs down from a 6" mini dish that is pointing at my ISP which is a couple of miles away.

God knows what is happening inside my ISP. I have asked him if there is a second NAT in his room.

I can’t send you pictures of things that are not in my house. It really is just the NUC and one router.

Please provide a link to their website.

I suspect that the setup is a microwave link to extend a network from one location to another. So the “internal” network is spread over two locations. If that’s the case, then the router connecting to the internet is at the base location, not Roland’s location.

I also suspect that ISR communications are the people who have provided this microwave link, and that they may not be the actual ISP…

@Rols - I think we need more information about the company who have provided your microwave link.

1 Like

Oh, you might be into something here.

My ISP is

But he is a guy in a flat with 18 cats and a fibre link. He has rigged up links to a small housing estate that was missed out by the big players. He might well be buying a high speed line from a real ISP and dividing it amongst his customers. There might well be a router between the other end of the microwave link and the fibre. I will ask him.

My ISP is saying to me “you have a fixed public IP starting with 82. and you have a private set off addresses starting with 192…, the translation is being done by your NAT. I do not have another NAT”.

So I am still stuck. How do I get my rock to talk to the outside world?

@Rols, please share model numbers of all Devolo kit you are using, so I may take a look at these. Thanks.

OK, I will do once I am back at home, but I have tried to install my NUC directly wired into the back of my router and still found the double NAT problem. I posted the resulting error message above.

I can’t see how it can be the devolo gear as I have tried removing it all.

1 Like