Comcast XB6-T modem/router

I’m on Comcast/Xfiniti

Hi @AndersVinberg,

I appreciate the detailed feedback, it’s immensely helpful.

Do you have any routers other than the Pakedge RT-3100 in your setup? Some ISP-supplied modems also have built-in routers, so we want to redundantly confirm only one router is between your Core and the internet.

The issue appears to be that there’s an additional layer of NAT (possibly at the level of your internet service provider) which is preventing your router from reaching our servers. If this is at the service-provider level, we’re working on a way to forward external traffic, but we don’t have a solution at this time.

The team is going to look into your case to see if it’s a local configuration issue or the ISP issue I’ve outlined above. Stay tuned and we’ll circle back shortly!

I will do some more investigation.

AFAIK the system looks like this: from the ISP (cable) there is a modem, a router and a switch. The WiFi system (Ruckus) has four access points around the house, they are wired into the router, they do seamless handover for mobile devices, like Eero. They can be configured in a mesh, but all of mine are hardwired to the router.

I don’t really know what the switch does, probably it’s for connecting other services like the burglar alarm.

What I don’t know is if the modem has some kind of NAT feature in it. It’s provided by Comcast. I can’t see any model designation. I had a device from Comcast that looked like that, and I think it was a full-fledged WiFi router.

Hi @AndersVinberg,

The team took a deeper look into this and we suspect the Comcast XB6-T modem/router is the culprit here. That unit is set up as a router by default; with the second router in the setup, there’s an additional layer of NAT here.

You’ll need to set it to modem-only by navigating to the admin tool in a web browser and entering the username and password taped on the modem.

From the left-hand column, select Gateway > At a Glance.
Next to Bridge Mode, click Enable.

Here are more detailed instructions from Xfinity.

The Comcast unit should power cycle automatically, but perform a manual power cycle once or twice if not. That should disable the additional NAT layer which is causing the error with automatic configuration.

Please be sure to also reboot your Packedge router before testing again with automatic configuration at your convenience. :slight_smile: We’ll be here to support once you have a chance to try these steps!

1 Like

Yes, I had just come to that conclusion, my tech guy confirmed that the modem had that feature (as I expected), so I finished my lunch, logged into the modem, it was set to include the router capability, i set it to Bridge Mode which disables that stuff, everything went down because of the dependency chain, I hooked up my laptop to a wired connection (had to locate a USB-C to RJ45 adapter for my MacBook), and by the time I was online again, everything was up including wifi. So I went to the regular Roon remote, Settings/Roon Mobile, it tested and said Ready, I restarted the Roon Mobile on the iPhone with wifi, all good, then turned off wifi, and Roon Mobile worked over cellular.