Configuring a WD My Cloud for SMB instead of AFP [Solved]

Hello, All,
I just downloaded Roon to try. Everything I read sure has me interested. However, I am running into problems.
A bit of information about the infrastructure I am presently using:

  • Mac mini (mid 2011) with 8G memory
    • 8 G RAM
    • 500 GB HD1 - 300G free
    • 500 GB HD2 - 170G free
    • WD My Cloud 4TB
  • OS X Yosemite 10.10.5
  • Presently using JRiver Media Center 20

I have all my music on the WD My Cloud disk and Media Center can see all my music. All music is ripped to FLAC.

I am trying to get Roon to “import” my music off the WD NAS. Everything is mounted via afp. I have not been able to find any information on mounting via SMB. Any pointers or help from anyone? If I cannot get this sorted out, I will have to leave Roon behind until afp is supported.
Thank you,

Found the issue after a few more hours of digging. Just wanted to let you all know.

Hey Dale! Sorry for the slow response here – how did you get this resolved?

Hey, Mike,
Man, are you gonna make me fess up to my silly mistake? :wink:

I was able to figure out how to “mount” the WD My Cloud disk using SMB. I have never had to deal with anything other then the default network mount in the past (afp). I just logged into my WD My Cloud console and retrieved the STATIC IP address I assigned to the device many months ago during initial setup. Once I had the IP address, I just did the following:

  1. Finder --> Connect to Server

  2. Entered smb://IP address/, clicked on “+” to add to the list of Favorite Servers

  3. I then highlighted the new server in the list of Favorite servers and clicked on Connect.

  4. Viola, all mounted and roon is now happy.

Let me know if it would assist the community if I take screen shots and attach them to this thread (assuming I can attach/upload screen shots). I would be more than happy to do so if you feel it is of value to the community.

However, after an all night import (I have somewhere between 18,000 - 22,000 tunes), I am discovering roon has not loaded more than a few albums. Not sure if any artists are missing yet. For example, I have all of Rush’s albums with a few remastered ones for about 26 albums. Roon only found 5… I am digging around on the forum to see if I can find any similar issues and solutions. BTW, I entered a separate thread for this issue.

So far, I am liking Roon. If I can get the missing album issue resolved, I will most likely take on an annual subscription for this year.
Thanks, Mike.


Heh, sorry :slight_smile: – just like to make sure we know how things worked out!

I saw your other thread, and unfortunately Roon doesn’t support single files and .CUE sheets right now, so my recommendation would be to split those up or make a split copy for Roon (@danny talked a little bit about the reasons here).

If there’s anything else I can help you with @Dale_Neidhammer, or if you have any other files failing to show up in Roon, feel free to update the other post or PM me directly.


Hi @Dale,

I also use the WD My Cloud, and have made it work with SMB, as per your very helpful explanation.
Problem is if I disconnect my wire I need to redo everything…
(as per your described steps)
Is there anyway of making the OS remember these settings…?

(I run El Capitain)

Thanks in advance,

Hey Dale,

Thank you for your post. I think I have the same problem as you. Basically all my music in my WD My Cloud is in FLAC format and I use a Macbook Pro. When I try to add my WD My Cloud library (which has music in FLAC format), Roon says exactly this: “Watching AFP-mounted folders is not supported. Please use SMB instead”.

Could you please go more into detail as to how you fixed this issue? I did not really understand how you were able to mount the WD My Cloud disk using SMB. How did you retrieve the STATIC IP exactly? Then when you went on Finder, how did you connect to the server and where did you enter the SMB://IP address? I’m sorry I guess I’m not such a high tech person. If you could just go into more details as to how you did it step by step I would be very grateful!

Thank you so much.

@Mike Could you tell me how to mount watched folders using SMB instead of AFP? I use an OS X Macbook.

in finder GO -> connect to server … you’ll see something like this. just replace afp:// with smb://

then add the drive to your log on items for automatic mounting when you start up your mac

Thank you very much Steve. I did what you said but it did not solve my initial issue :pensive:
My issue is the following: Basically all my music in my WD My Cloud is in FLAC format and I use a Macbook Pro. When I try to add my music library (that’s located in my WD My Cloud which has music in FLAC format) to Roon, Roon says exactly this: “Watching AFP-mounted folders is not supported. Please use SMB instead”.

I’m unable to add the music from my WD My Cloud storage to Roon. All my music in my WD My Cloud is in FLAC format and I use a Macbook Pro OS X Yosemite (10.10.5). When I try to add my library located in my WD My Cloud storage (which has music in FLAC format), Roon says exactly this: “Watching AFP-mounted folders is not supported. Please use SMB instead”. I’ve tried switching to SMB but it’s still not working. Maybe I’m not switching to SMB properly. This has been dragging for days I really hope it can be fixed. If anyone knows what to do, please let me know (in detail). Thank you very much.

Hey @Ramy_Accad – sorry this has dragged on so long – I missed your flag above when I was out last week :smile:

So, we’ve heard from a number of users with WD My Cloud having similar issues, and this device does seem to be a little more tricky to set up than other NAS drives. That said, as far as I know everyone’s been able to get this working, so I’m sure there’s something we’re missing here.

You’ve followed the instructions in @Dale_Neidhammer’s post above right?

Hey Mike! No worries at all it’s not your fault :smile:

Yes I’ve followed @Dale_Neidhammer’s post and it still did not work. Perhaps I did not do it the right way (although I followed every step just like he did). Maybe with screen shots it would be clearer.

Hey @Ramy_Accad – have you tried connecting to the NAS using Roon’s network folder functionality?

I’m guessing there’s a setting in the My Cloud configuration that allows for SMB, but once that’s set you should just be able to follow these instructions, as opposed to mounting the drive in OSX.

Let me know if that helps or if you’re still stuck and we’ll figure this out. Thanks!

Hi Mike! Thanks for your concern. I followed Dale’s instructions and I was able to make it work through SMB however I ended up having the same problem as Bjorn_Bengtsson, where every time I shut down my computer, it forgets the network and hence all my music gets erased on Roon and I have to redo the whole process again. I tried contacting WD My Cloud regarding connection through SMB instead of AFP but no answer till now. Not sure what to do anymore :’(

You need to mount the NAS before you open Roon. Just hit Command-K and mount it as per instructions. Then run Roon. I do this all the time.

Hi Bjorn,
Did you find a way for OS to remember the settings?

What settings are you referring to?

What you can do is add the volume to Start objects in Users an Groups. It will then mount automatically after a re-boot.

YES! You saved my life dude! Finally! :smile: A million thanks to you!