Configuring MQA via Tidal

Having issue with playing Tidal MQA via Roon… and trying to understand if there is a configuration setting that will resolve this.

When streaming Tidal via Roon directly to my primary DAC (Madrigal Labs), whenever the source file is MQA I get only silence. Roon thinks it is playing, but there is no sound. If I play the same material via Roon to my Sonos as endpoint and then into DAC, it works fine.

Signal paths are:

  1. Roon Core server (Mac Mini) -> network (wired ethernet) -> Sonos -> coax digital -> pre/processor/DAC
  2. Roon Core -> network -> Allo DigiOne -> coax digital -> pre/processor/DAC

While doing some other audio testing recently, connected a second DAC (Rega) in parallel to the DigiOne, and this was able to play MQA from Tidal.

path here was:
Roon Core -> network -> DigiOne -> coax digital -> Rega DAC -> RCA connection (analog) -> pre/processor

This leads me to believe that Roon core is “dumbing down” the MQA stream to something the Sonos can understand, but sending different stream to the DigiOne thinking it is more capable.

DigiOne is configured as shown.

Any configuration suggestions here?

Your best if you post an image of your signal path playing an mqa file to your digi one and DAC. Do you have MQA core decoder switched on? Also does your DAC support MQA ? As you will only get Roons core decode if not anyway.

Roon Core is decoding MQA.
(FWIW, I’ve not seen a switch setting to turn this on/off anywhere; rather, only settings for the endpoint re. MQA capabilities, as in screenshot in initial post)
None of my 3 DACs are MQA capable.

Here are the requested signal path images.

All seems good for the Allo. You can turn off the core decoder in advanced but of the device settings. It’s on by default. If you have a DAC that does not decode mqa it should still work and it will receive 96/24 from Roon. I assume the DAC supports up to that. You could try turning off mqa decoder to see if this helps. Have you adjusted the volume of the device ? It should be set to fixed or be at 100% for MQA to pass through.

thanks… will try fiddling with settings from your suggestions

I thought Sonos gear was limited to 16/48; which would explain the signal path for you Sonos.

Sonos isn’t the issue here - it works fine. Trying to solve for DAC connected via Allo DigiOne

Your primary DAC seems to be really old, so whether it supports 88.2kHz and 96kHz (result of MQA Core decoding) is unclear to me, and I am unable to find it from google.

I suggest you confirm that first, either by checking the manual if you still have it, or use Roon DSP Engine to upsample non-MQA music to 88.2kHz and 96kHz to check whether the DAC supports these rates.

If your DAC does not support these rates, you need to turn off Roon MQA Core decoding, so that MQA is not output to higher than 48kHz.