Configuring Roon Arc for Remote

Roon Core Machine

Windows 11, Intel i9, 32GB RAM

Networking Gear & Setup Details

Netgear Nighthawk R9000, (34 connected devices - mix of ethernet and wifi)

  1. Who is your internet service provider?
    Verizon Fios Gigabit Up/Down

  2. Please list the make and model of your modem and router?
    Netgear Nighthawk R9000 set to ‘router mode’

  3. Do you have any additional network hardware, like additional routers or managed switches?
    No

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No

Connected Audio Devices

Sonos Speakers, iPad, iphones, iOT cameras, thermostats, etc.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“74.ggg.hhh.iii”,“router_external_ip”:“null”},

“status”: MultipleNatFound

,

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true}

}

@Kevin_Brehm, sorry to hear about your issues on getting ARC configured.

he diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  1. Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core, and on the FiOS router
  2. Try to manually open the port both your routers’ port forwarding configuration
  3. Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  4. Check for any VPNs or Firewalls that might be interfering
  5. Check if your can can configure your FiOS modem in Bridge mode, or the R9000 in Bridge mode

Hi @Kevin_Brehm,

The error status MultipleNATFound could have 2 reasons:

  1. you have more than 1 router in your setup
  2. Your ISP is using CG-NAT

My question is, is the Nighthawk R9000 the only router or do you also have a router provided by your ISP?

If you also have a router from your provider, can you set this device in bridge mode?

Kind regards,

Maarten.