Connecting Roon ARC correctly

Roon Core Machine

Win11-64bit, 32gb ram, latest intl cpu

Networking Gear & Setup Details

Genexis DRG7820 with Gigaclear

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Can’t connect Roon ARC - I have a screenshot I can share

Welcome to the Roon community, @Claude_Bovet.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hey @Claude_Bovet,

Following up on this thread, I wanted to check in and see if you were still running into issues getting Arc squared away? @Martin_Webster has provided excellent next steps if so.

I’ll be monitoring this thread for your reply :+1:

1 Like