Connecting to WD NAS on ROCK

Hi I’ve set up a new ROCK on a NUC. I’m on a Roon remote on an iPhone trying to add my WD network server as a NAS drive (yes I know that WD isn’t a real NAS; I’m in the process of moving away from it).

I keep getting “Unexpected error”. I’ve tried all combinations of using the IP address (\\192.168.1.236\Public and smb://192.168.1.236/Public), the name (\\MyCloudPR2100.local\Public and smb://MyCloudPR2100.local/Public) and using no username and using “guest” as the username.

I’m running OS version 1.0 (build 227) and ROCK Version 1.8 (build 1021)

Note: this used to work. I used to have the Roon core on a Mac that uses this NAS just fine using guest as the username and the name MyCloudPR2100.local/Public. In the Settings->Storage for that core it said the storage was “\\MyCloudPR2100._smb._tcp.local\Public”.

So what am I missing? Thank you.

I’m not familiar with the WD MyCloud device, but it’s not clear from the manual what the user credentials are for the Public shares.

You may be better off creating user shares on the NAS with specific user credentials (username and password), and then using those in Roon.

Yes, it’s not very clear. What I do know is that on my old Mac core, it didn’t ask for any credentials. I’ll take your advice and try with setting credentials and using and see what happens.

There is a FAQ on configuring NAS for Roon and there is a section detailing WD NAS

Roon NAS FAQ

Section quoted below

Configuring a WD My Cloud for SMB

The WD My Cloud is not a full-featured NAS device, but it can be supported by adding a folder in Roon’s settings and entering your credentials and the network path. It would look something like this:

  1. smb://ip address/share/folder

So for example, it might look like this:

  1. smb://10.0.1.2/music/Roon

This ensures that your share is always mounted by Roon, bypassing the OS X Finder altogether. If you don’t know your My Cloud IP address, you can find it in your My Cloud dashboard. Failing that, you can try these instructions for mounting your NAS as a startup item, just replace afp:// in the article with smb://

Yes, I consulted it already. I’ve tried all the versions that are mentioned in there.

Figured it out!!! I feel so smart.

What Roon doesn’t tell you is that ROCK doesn’t do SMB2 out higher protocol. Once I changed the WD NAS to use SMB1, worked immediately. Hopefully someone who sees this will tell the Roon powers that be.

Here’s where the setting is. Go to Settings->Network:

Of course, there’s no free lunch. My Mac and iPhone can’t connect to it. I guess they expect SMB2. Oh well.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.