Connection Failure troubleshooting

I have Ropieee running on a Pi3. It worked great for a few months, but in recent weeks, it’ll flip back and forth between the Now Playing data, the “Connection Failure” screen.

I haven’t changed anything recently, so I’m at a loss as to what might be happening.

I’ve done the traditional troubleshooting of power cycling the box, verifying my LAN is working properly, and whatnot.

I’d love some troubleshooting advice. While I like the appliance-like nature of the Ropieee image, it’s difficult to get insight into what might be wrong. Are there logfiles available somewhere?

You can send me feedback. Go to the ‘advanced’ tab and hit the ‘send feedback’ button.




Hmmm… that’s weird. Did not receive anything…
That points to possible network issues.

Are you using cable or wireless?


I’m sure you’ve heard this before, but I’m very confident in my network configuration. :slight_smile:

Hi, i seam to have the same issue

Feedback 7a787d0074e5efad

Best regards

6d168c793f64672b Similar issue, cycling a “Connection Failure” screen every minute or so, lasting a few seconds. Playback is uninterrupted. Hardware is Pi 3, name brand SD card, Pi official touchscreen, Hifiberry Dac+ pro, all powered from USB hub, hardwired w/ cat6 to a netgear unmanaged Gb soho switch, 10m distant. Operator is SSH capable.

Well, you only have one zone in your Roon system available, called ‘Kitchen’. But you’ve configured the display to control the zone ‘Living Room’. So that won’t work.


Totally missed your message.
What’s the status? Do you still need support?


@spockfish Firstly - Thank you for RoPieee, and thank you for taking the time to look at feedback. My system is basically working; so these are all annoyance-level concerns at worst. I’m grateful for any thoughts offered, but music is playing and I’m happy.

I’ll double check my zone configuration; I may have introduced a sampling error when I collected the debug package. I normally have 3 zones - a RoPiee as the ‘living room’, two headless DietPis as ‘kitchen’ and ‘garage’. Livingroom and Kitchen often get grouped for background listening. Maybe there’s a lingering issue with the grouping/ungrouping?

Further possibilities: I’m wondering if I have a power-quality issue; the USB hub powering ropieee is nominally rated for 3A, but may be limiting per-port current. I’m running the Pi & Dac from one port, and the touchscreen from another.

The Kitchen endpoint runs on WiFi where the others are hardwired… That’s enough layer-one difference that perhaps RAAT has complaints.


I’m having the same problem. One thing I’ve noticed is that the host name is not resolving. If I enter http://livingroom.local into a browser, it times out, but if I enter the IP address, I can access the GUI. Russian hackers?

BTW, music is playing just fine through the end point.

Have you tried without the grouping?

Again, in your log there was no LivingRoom, also not grouped. So if the configured zone is not detected then it cannot control it and shows the connection failure message.


Pretty sure no Russian hackers :wink:

Anyways, things seem pretty normal, except that the extension can not find the Roon server.
Did you enable the extension in Roon?

Thanks Harry. The extension was not showing up under “Discovered Roon Extensions” but was showing up under “Authorizations”. I tried restarting Roon and Ropieee, but I was still unable to enable the extension. I restarted my computer and the router and then was able to enable the extension. Thanks for you all your help.


1 Like

By the way, I still don’t know why I can’t access the GUI using the hostname.local address.

Well, it requires that your infrastructure supports ‘local link’ feature, that’s what the ‘.local’ means.

So should be able to go to the website by accessing http://hostname

That should work always. If not then there’s something wrong.


I’m having the same issue here. Tried everything (I think) to get the rp3 to display on the rp3 screen.

The only thing I cannot seem to find are the extensions your referring to.

Could use some help


Hello Jeremy,

The extension can be found in Roon —> Settings —> Extensions. I presume that you have configured RoPieee with a valid Roon Zone?