Connectivity error code 504

Microsoft Surface Roon Core Machine
Windows 11, Intel Core i5 8 GB RAM

Networking Gear & Setup Details

ORBI RBR50 Wireless Router connected to internet vis Xfinity modem XB7-T

  1. Who is your internet service provider? Xfinity

  2. Please list the make and model of your modem and router?

Xfinity modem XB7-T
ORBI RBR50 wireless router
Local music stored on a Western Digital MyCloud NAS

  1. Do you have any additional network hardware, like additional routers or managed switches?


  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?


Connected Audio Devices

Chord USB

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

The Roon system is working fine but Roon Arc is unable to securely access my Roon Core

Roon Arc serves the following diagnostic message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Is this in bridge mode or is it acting as a router?

I just checked and confirmed that the xfinity modem is NOT in Bridge Mode.

Then you’ve created a “double NAT” problem.

The XB7 either needs to go into bridge more or the Orbi needs to go into bridge mode. If none of that makes sense… well… I’d need more time to type it up :slight_smile:

The other option, which might work, is you’d need to manually put a port forwarding rule in 2 places:

  1. The XB7 pointed at the Orbi WAN IP
  2. The Orbi pointed at the Core IP

The port used for these forwarding rules needs to be the same as reported by Settings → Roon ARC

That is, it needs to be the same through the network all the way to Core and it needs to match what is configured on the Core.

Wow, it worked! I put the xfinity modem into Bridge Mode and Roon Arc is Ready! THANK YOU!

Now, I just hope Bridge Mode doesn’t trip up other smart devices scattered around the house. One day at a time, right?

1 Like

yes, solve one problem to create another? The endless cycle… you’ve earned your “network engineer” badge :stuck_out_tongue:

It all depends on if anything was plugged into or attached to the XB7. If you never used its wifi, and the only thing connected was the Orbi, then you should be good to go. If something was connected to it then you should be able to just reconfigure it to use the Orbi at this point.

Thanks again! I am looking forward to streaming my music remotely :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.