Core and Tidal are missing in action / disappear


Roon Version 1.2 build 165 Win 64 bit stable
OS Win 10
Dell XPS 15 as remote (or core)
SMG sonicTransporter i5 as core
Sonore microRendu as audio device
Tidal only for streaming (no stored music files)
Just over 20K Tracks


sonicTransporter not recognized. If I disconnect it from the router and reconnect SOMETIMES it will be recognized.

Using the IP address scan does not work.

Tidal is not recognized. Even when with the re-login window in Roon.

System defaults to no tracks/artists/albums, etc.

If I uninstall Roon and reinstall it I can get it working as I had it set up (PC as remote; sT as Core; microRendu as audio device) but only for a short time.

It goes back to no sonicTransporter and no Tidal

NOTE: Roon is unable to retrieve my Account in the Settings Menu, which means I cannot logout and reset.

NOTE: Tidal shows as NOT Configured under Services/Settings Menu.

NOTE: This above setup was stable for over a month.

NOTE: I do not want to use my PC as the Core.


  • David.

Reboot the core, that is what solved an issue like this for me. Suddenly my account was back, along with Tidal.
Good luck.

Hi Chris. Thanks.

Can you explain what you mean by rebooting or restarting Roon Core?

I think I have been doing this…but figure I should ask for specifics in case I am not.

BTW - it has hung up twice since I logged out and reloaded running the PC as core. The latest hang up shows that it no longer recognizes the microRendu as well.

  • David.

If you are referring to rebooting the pc, I did do so. Roon came up and recognized the sT and the mR, but keeps giving me an error message for the Tidal login. And the Account Info under the Settings menu is again not accessible or visible.

I have the 60 Trial Subscription via the Small Green Computer sonicTransporter purchase.

As a new user, have to say Roon support is also MIA…this concerns me given the licensing fee and the fact that what I am experiencing has clearly been experienced by others and is still ongoing.

Try rebooting the sT; that is where your Core is running.

Roon @support will be along shortly to help (and if they’re not we Mods will shout out until they do !); keep in mind that most of the support devs may be in a different time zone to you.

Edit: Is there a firewall operating on your PC ? If so see this KB page. You need to enable access for Roon and RAATServer processes if the firewall software hasn’t asked and obtained authorisation for them.

I have rebooted the sonicTransporter.

I have cleared the Roon Cache per other threads.

I turned my firewall off, also per guidance.

I have rebooted my PC.

I have uninstalled and reinstalled Roon.

I am still getting the same error messages regarding Tidal login within Roon (Tidal loads fine on its own so no issues there) and an error retrieving Roon account information.

Other threads also highlight the same issue. It appears to have started once Roon updated to Build 165.

I had the same problem with Tidal and deleted the Cache where I had installed Roon core and that didn’t work. What did work was when I deleted the cache on my iMac which I am currently using as a remote. Did you try removing the cache from your Dell XPS? I see you have used it as a core and remote.

Hi @R_David_Sen ----- Thank you for the report and my apologies for the troubles here. Please be advised that we are actively investigating this problem your are experiencing as we have other members of our community who are in a similar state.

From previous reports we have seen the following procedures have helped a handful of our users restore stability to their Roon+TIDAL accounts:

  1. Restarting the Roon core / Roon Server.

  2. Clearing your TIDAL cache.

  3. Typing your login name (email address) in all CAPITALS.

Moving forward, I would like to confirm a few things to make sure I am conceptualizing your setup correctly as well as gather some more information from you in regard to this TIDAL issue. Please see below.

  1. Location of your Roon core.

Post #1: “SMG sonicTransporter i5 as core”
Post #1: “NOTE: I do not want to use my PC as the Core.”
Post #3: “BTW - it has hung up twice since I logged out and reloaded running the PC as core. The latest hang up shows that it no longer recognizes the microRendu as well.”

  • Currently your PC is acting as your core, correct?

  • Furthermore, when the PC is acting as your core it will recognize the SonicTransporter and the MircoRendu BUT you are still unable to connect to your TIDAL account, correct?

  1. You mentioned that this setup was stable for a month, has anything else changed in that time besides the update to Build165? OS updates? Firmware/driver updates? New gear added to your setup? Looking for any new variables that may be causing you to experience this problem.

Lastly, I am going to be merging this thread (once you’ve responded) with the one mentioned above to keep this issue isolated into one spot so if there are any recent developments or fixes, everyone will have access to this information.


Hi Eric,

I did all three things (1, 2, 3) during the posting of my troubles…gleaned from the other threads dealing with the same/similar issues.

None of the ‘procedures’ helped.

Addressing the second set of questions and to confirm for you…

  1. The only way I have been able to listen to music via Roon- Tidal has been by setting my PC as Core. The PC as Core has now been stable for just over 24hours…it took me nearly a day of rebooting and reinstalling Roon before this state of stability.

  2. The sonicTransporter is recognized in the initial start page for setting up Roon but if I selected it as Core, then things revert to the issues described earlier.

I do not see it recognized when the PC has been setup as core.

The MicroRendu is recognized and it is what is enabled as an audio device for my listening…currently with the PC as core.

And yes, Roon is and was set to discover Remotes.

  1. As for changes, there have been no hardware changes. On the software side, the usual automatic Windows 10 updates.

I believe that the sonicTransporter and microRendu were running version 2.3 before the troubles began. They are currently running the same, version 2.3

Thanks for your assistance and support.

  • David.

Hi andybob. Thanks. The Windows firewall was on while the system was stable for a month. I turned it off per the recommendations in other threads. Turning it off did not help with the issue I am having. It is back on for obvious reasons and with the PC as Core, Roon has been running stable for over 24 hours.

Hi Steven_Edwards. Thanks.

I did delete the Roon cache on my PC, the Dell XPS, a number of times after each successful load (when Tidal also loaded) and then crashed.

If you are referring to deleting the cache on the sonicTransporter, I am not sure how to do so, or if it is possible by the end user?

Hi @R_David_Sen ----- Thank you for the follow up and the feedback. Both are appreciated!

In reference to your most recent post, there is a way to delete the cache on the ST as Andrew has the procedure for exposing the RoonServeDB listed here.


Just expose the Roon database click on the cache folder and press delete.

1 Like


Hi Andrew. Do you mean the Roon database cache folder on the sonicTransporter, per Eric’s post (above your post?)

Yes that is the folder you want to delete. Correct?

I was having the same problem–not able to log in to
Tidal from Roon for a few days now, although I could log in to Tidal without Roon. I followed Andrew’s instructions to delete the cache on my Sonic Transporter and that allowed me to connect to Tidal on Roon again. However, no Tidal playlists are showing up in my Roon/Tidal interface even though my playlists are all showing on the Tidal app itself.

On the playlists screen in Roon be sure that “Show Global Playlists” is checked.

Hi @R_David_Sen ---- Just touching base to see how things are going and to check if any progress has been made here. Let me know. Thanks!