Corrupt Roon Remote display on iPad Pro 12.9” 2020

Core Machine (Operating system/System info/Roon build number)

Innuos Zenith mk2
Roon Core v1.7 build 537 stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet between Roon core and Asus RT-AX92U, WiFi to iPad Pro 12.9’ 2020 running Roon remote

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to Mytek Brooklyn DAC

Description Of Issue

Hi Support.

Ive recently upgraded Roon remote from a 12.9” 2018 iPad Pro (which worked flawlessly and in portrait orientation) to a 12.9” 2020 iPad Pro which I am having trouble with the way Roon remote is displaying.

Both Roon core and remote are on the latest versions and builds (v1.7 build 537)
The iPadOS is on 13.4.1

Issue 1. Roon remote on new iPad Pro 2020 will not display in portrait orientation. Despite this being a big fix on the release notes of v1.7 build 536.

Issue 2. When opening the Roon remote on the new iPad Pro 2020, the display will become corrupt immediately and not show the full remote display. Instead showing two big black borders on the left and right of the track or album listing. See attached.
This can only be cleared by forcing the app to close and reopening.

I have a friend who has a similar issue on his iPad Pro 11” 2018 model. Except he often has to restart the entire device to get it to display correctly.

I have only had this new iPad for just over two hours and this corruption has occurred at least 4 times.

Is this a known bug and is there a fix I can put in place?

Please let me know if you need further information.

Thank you.


Hello @Rory_Sharp and thank you for the details! Here’s what I’d like to do:

  1. Please boot up the iPad and reproduce these issues you’re experiencing
  2. Reply to this thread when you do this so I can get a timestamp

I’m going to enable diagnostics on your account and take a look at what the device is experiencing around the timestamps you provide. I’ll take this information to our team here for further analysis. Thanks!

Hi. Thanks for your response.

I have restarted the Roon Core and performed a hard restart on the new iPad Pro.

16.15BST - Opened the Roon remote app on the iPad Pro. iPad was in portrait aspect, Roon opened in landscape aspect. Screenshot attached.
I then closed the app fully and reopened, and found that the Roon app opened in landscape aspect but with a corrupt display, black bars on either side of the centre panel.
I tried this three times, closing the Roon app in between each attempt but the issue has not cleared. Screenshots of issue attached.

16.20BST I deleted the Roon remote app from the iPad Pro and restarted the iPad Pro.

From 16.22BST reinstalled Roon remote and fired it up. No change in the orientation issue, displaying in landscape while the iPad Pro is in portrait aspect. However, still with black bars on left and right.

Hopefully the logs can show what is happening. Please let me know if you need further info.

Thanks for your help. Rory

Hello @Rory_Sharp, thanks for the info! I’ve submitted this information to our team for further analysis.

Hi @nuwriy,

Are you able to offer an update on this issue please? Will it be fixed in the next build?
I note that someone else has also experienced something similar on their iPad Pro.



Hello @Rory_Sharp,

There is good news! Our team is actively developing a solution that should assist you here. I found this post from Noris a few days ago.

Hi @nuwriy

Thanks for that. However, does the solution they are working on also include the black border issue in landscape mode that I raised in my second point in this post?

It seems like more people are seeing this, such as in this post which you commented on earlier today…

Cheers, Rory

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.