Crazy search bug [more typing crashes]

Roon Core Machine

Device name Paul-Inspirion
Processor Intel(R) Core™ i5-4460 CPU @ 3.20GHz 3.20 GHz
Installed RAM 8.00 GB
Device ID FE8EC9E6-04F4-4CF4-9567-44CFA17803E5
Product ID 00326-10000-00000-AA283
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Edition Windows 10 Home
Version 21H2
Installed on ‎11/‎1/‎2020
OS build 19044.2486
Experience Windows Feature Experience Pack 120.2212.4190.0

Networking Gear & Setup Details

Astound ISP fiber & router

Connected Audio Devices

Cambridge Audio Magic DAC

Number of Tracks in Library

20,000 tracks

Description of Issue

Whenever I do a search by artist or composer and filter by name, if the first letter of the string is a “k”, Roon crashes. It freezes for a moment when I hit the “k” key, then crashes, without fail. I have done this many times as a test, and it always works. If the “k” is not the first character, no crash. I have tried all the letters of the alphabet, and “z” is the only other character that does this, but only for artist, not composer.

This is a local issue as the problem doesn’t occur on my system.
It sounds like a probable database issue/corruption and it’s worth doing a restore which should be a fairly simple & quick process which is described in the link…

Failing that, reinstall the core…

Is your core and remotes up to date? Several such crashes occurred recently but were supposed to be fixed in the update 2 weeks ago. Possibly something was missed, or you are missing the update:

These were some of the older instances that were supposed to be fixed:

In the older instances, it didn’t happen for everyone immediately, either. Sometimes it was a question of having a specific timing of key presses. So it might be a local issue for @Paul_Farrar that is different from the old cases or you might not have typed in the exact same way :slight_smile:

1 Like

That’s certainly a possibility but I tried numerous combinations of K & Z before posting …

I experience the same issue with the letter “k” only in Artists - Filter.
If I enter 2 letters quickly, such as “ki” there is no issue !?

No issue with the letter “z” though. Very weird.

Important remark, the problem occurs on Roon Client:
Laptop Windows 11 : YES
iPad iPadOS: 16.4.1 : YES
Samsung S10e Android 12 : NO ISSUE

It is becoming even more weird. Let me first show this picture.

If I first Focus on Artists - Qobuz Library - filter with “k” is no problem
If I Focus on Artists - linux1 - filter with “k” is no problem
If I Focus on Artists - linux2 - filter with “k” , the issue occurs.

So, one would think that there is an issue with (part) of my Local Library.
However, if I first Focus on e.g. Qobuz Library

and then, keep the filter and remove the Focus, then it works normally (i.e. no issue):

Now it is really driving me nuts:
After I have done this 2 steps (1st focus, then remove Focus) - it keeps on working fine , e.g. I can search on the letter “b” , and than “y” and then “z” , and then “k” the issue does not present itself.

Problem solved? Not so quick!!!
On my iPad I have the same behaviour:
filter with letter’“k” in Artists killed the app.
Focus first on e.g. Artists - Qobuz Library , the filter “k” - works fine.
Removing focus , filter “k” keeps working OK.

Focus on “k” after this step, keeps on working fine, untill you do something else, 2 examples:

  1. switch from Artists view to Album view, leaving the filter “k” (i.e. no reset of the filter)
    go back to Artists view and the app will close itself again.
  2. close the app yourself (i.e. closing Roon Client)
    After starting up the client again, problem reoccurs.

I retested on my Windows laptop, same behaviour.

(But as indicated before, no issues on my Samsung phone)

Very bizarre indeed.


Details on your Core machine (OS, Hardware specs, Roon build)

  • Pinkfaun 2.16X Server, running on Audiolinux, AMD 7 3700 processor, 16GB RAM, 1 HD Samsung SSD 250GB for Roon + 2nd HD Samsung 4TB SSD for local music
  • Roon version 2.0 build: 1244
  • HQPlayer: HQPlayer Embedded 4.31.0

Details on your Remote(s) (OS, Hardware specs, Roon build)

  • iPad Air Pro – 128GB - running iPadOS 16.4.1 - Roon version 2.0 build: 1242
  • Samsung S10e – running Android version 12 kernel 4.14.113-25257816 – Roon version 2.0 build: 1242 Wifi 6
  • PC running Windows 11 Home - 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz Ram 16GB, Roon version 2.0 build: 1244

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

  • Ethernet & Wifi Mesh network (Wifi 6) built on 3 * Asus Zenwifi XT8
  • Connected to Service Provider modem
  • Speedtest connection speed ethernet 93Mbps download – 18Mbps upload
  • Roon Core connected via ethernet, Remote PC connected via ethernet
  • Mobile Remotes connected via Wifi6

Audio devices in use

  • T+A 8 DSD connected to Roon Core, using HQPlayerEmbedded, connected via USB
  • Endpoints : 1 * Cambridge Audio CXN v2 , connected via ethernet

Library details

  • Local library on separate internal 14TB + 12 TB SSD harddisks in Roon Server
  • Qobuz Hi-fi Sublime streaming service
  • 62194 tracks (4176 albums – 2421 local, 1755 Qobuz)

Backup details

  • Location 1 : USB disk connected to Core Machine - 2GB capacity
  • Location 2 : Synology NAS 10,8 TB capacity
  • Location 3 : USB disk connected to Synology NAS - 7,2 TB capacity

I edited the topic title to clarify what it’s about

Thank you for posting about this issue. The devs have been notified about it.

Roon Remote on my iPad crashes when I try to filter artists and typing the ‘u’ as the first letter. If I’m quick and type ‘ute’ it doesn’t crash, but when I delete the ‘te’ using backspace, it will crash after that.
Roon Remote on my Android phone doesn’t have problems like this.

I also discoved that with the band Einstürzende Neubauten, both on iOS and Android, the filter phrase is displayed with an extra letter in front of it, which can be seen in these screenshots.

But also, there is a possibility that a letter is dropped, like here, where the ‘z’ is missing in the name:

Apparently, there is a problem with the umlaut: every letter after it is dropped, like in this example…

And here:

Roon Core Machine

Sonic Transporter i7 running windows 10

Networking Gear & Setup Details

Ethernet network Synology Router RT6600ax

Connected Audio Devices

DCS Rossini (Ethernet)

Number of Tracks in Library

40, 000 tracks

Description of Issue

ROON crashes when searching on either iPad, iPhone or PC (Ethernet)
Search word “DAU” and crashes immediately after typing the “U”, but OK if search “DAI” or other words

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.