Crestron analog values


(Timothy Lee) #1

@support

I am interacting with a nucleus + using your build 6 modules on a Crestron control system. I had initially tried to do all my volume controls with direct volume levels, but I found that after a few rapid changes the nucleus starts ignoring direct volume commands. I have now found this occurring even on infrequent use of direct volume commands, do you have a best practices for dealing with direct volume commands?


(Timothy Lee) #3

I was told by the integrator Bryan to include @steve onto this message.


(Noris) #4

Hello @Timothy_Lee,

Thanks for contacting support, the feedback is always appreciated! If I could kindly ask you a few questions to clarify the issue that you are having:

  • How you are setting direct volume levels? Is it with our slider built into the VTPro projects or have you modified your project to accept direct values?
  • Are you using the Volume or VolumeNormalized analog value in the device module?
  • Can you confirm that the device you are using accepts different volume options and is not a “fixed volume” device?
  • If need be, would you be comfortable with sharing your modified project with us so that we can take a look?

A little background on the volume function - the volume control commands are forwarded from the interface to our SIMPL# module which talks directly to our Roon API. While I am not sure if the best practices guide applies directly to SIMPL# modules with API calls, we can certainly take a closer look if you can point us to the proper documentation.

Thanks,
Noris


(Timothy Lee) #5

Sure thing,

  • I am not using a slider this project does not currently a graphical interface. I am a sending a 0-65535 value into the volume normalized analog input.

  • Can the Nucleus + be set as a fixed volume device? If yes, please let me know where to check for that setting. I don’t believe this to be the case, as I am able to modify the volume with the analog sometimes, and always with the digital volume up and volume down commands.

  • I am comfortable sending you the program, but not comfortable posting it here.


(Noris) #6

Hello @Timothy_Lee,

Thanks for your replies.

Just to clarify one point, you are not using a DAC with fixed volume controls and you are just using the HDMI out from the Nucleus+ connected to an AV receiver correct? You can set fixed volume controls in Roon Settings -> Audio -> Cogwheel Icon Next to Desired Audio Destination -> Device Setup -> Volume Control -> Fixed Volume. However, I don’t think that setting it to fixed volume will help in this case here since you are trying to change the volume from the interface.

I was asking this question more in regards to if you have a DAC connected to the Nucleus which can only accept changes in volume using the physical device controls itself but I do not think this the case here, please confirm if possible. I will PM you shortly on how to upload files to our server, if you can send us the project to have a look that would be great. If you also have the documentation available, we can certainly take a look there as well.

Thanks,
Noris


(Noris) #7

Hello @Timothy_Lee,

Thank you for sending the project to us. I have been testing it for a bit and the volume controls seem to be working fine from my end. Just to confirm where the issue lies here are the steps I have taken so far:

I have set zone z-01 in Roon as an analog output to one of my connected USB devices that that supports volume control:

  • I have set the Set/Reset latch digital signal ‘z-01_roon_stop_vol_control’ to high so that ‘z-01_disable_amp_control’ can enable the volume buffer

  • I have pulsed both ‘z-01_Volume_Up’ and ‘z-01_Volume_Down’ in SIMPL Debugger for ~10-30 seconds at a time and I see the volume changing from within Roon and on my volume settings.

To perform some further testing, I also did the following:

  • Edited the oscillator to use ticks instead of seconds, with a ‘hi_time’ of 1t and a ‘lo_time’ of .1s.
    System is still responding to volume changes at this point and even a bit better since using 1t instead of seconds pulsing method

  • I tried setting the ‘lo_time’ under .1s and could see a delay between when using the volume commands the change on Roon’s side would take a bit of time to process. It seems that .1s 'lo_time" is the minimum time if using an oscillator where the module has sufficient time to process the API calls properly in the background.

As shown above, I have been unable to reproduce the issue you are experiencing. Please let me know if I performed one of the above steps incorrectly or if you have other more accurate reproduction steps to display this issue on my end. I look forward to your response.

Thanks,
Noris


(Timothy Lee) #8

Noris,

The oscillator is not the issue, it was the workaround that I created for volume up and down. The direct volume command that goes to the device when switching to the source was the issue. I will PM you with the details on a different version of the program so that there is less confusion.


(Noris) #9

Hello @Timothy_Lee,

Thanks for sending us the project which highlights this issue. I was able to reproduce something similar to what you’re describing so I’m going to pass this thread to our technical team to take a look at, and I’ll get back to you with an update soon. Thanks again for the report and the sample program.

Regards,
Noris


(Noris) #10

Hello @Timothy_Lee,

I appreciate your patience while we revised our module, we have just released Build 7 of our Crestron Module and it is available for download at: http://kb.roonlabs.com/Crestron. We have various performance improvements and re-wrote part of the Volume feedback so that Analog Ramps will properly work. Please let us know how it goes with the new build.

Thanks,
Noris