Database Error and no Audio Devices found after update

Roon Core Machine

Intel PC Celeron J1900 CPU
4GB RAM, Win10 Pro 32-bit version

Networking Gear & Setup Details

PC connected via gigabit ethernet to Cisco SG110D-08 router.
Music stored on Synology DS214 NAS

Connected Audio Devices

Lumin X1

Number of Tracks in Library

35,000 tracks plus using Qobuz.

Description of Issue

After upgrading all devices to latest build, I get an “issue loading database error”.

I rebooted the PC and devices. No change. I followed the instructions in the knowledge base regarding database errors and tried restoring a previous backup, same problem. I then uninstalled Roon, deleted directories, then re-installed Roon . It proceeded as expected but then no albums plus Roon symbol keeps pulsing. Roon can see my shared folder on my NAS but will not scan or load albums.
My Qobuz albums are there.

No audio devices are detected including my Lumin X1. Tried re-booting that too. Note that all the above is identical on my Ipad & Android phone. I deleted and reinstalled Roon on them too. No change—no albums visible, no audio devices found. I’ve un-installed and re-installed Roon three times. Same issue.

No recent changes to network, no firewall or vpn or virus software.

Other music apps such as minimserver, Lumin, JRiver continue to work fine. All albums and audio devices visible and functioning. No problem accessing NAS anywhere in my network. Only issue is this latest build of Roon.


Make sure you have free space in your Roon database drive.

  • Stop Roon
  • Navigate to your Roon Database Location - Database\Registry\Core
  • Locate your tidal_account file and delete it
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Start Roon again
1 Like

A post was split to a new topic: There was an issue loading your database on Windows, build 880

A post was split to a new topic: No devices, no library after Roon 880 updates

Sorry Peter, I tried that, same problem. There’s a bug somewhere in this release that is breaking Roon for some users. I reported it when I was invited to join the beta but it doesn’t appear to have been addressed prior to release. Hopefully a fix is coming soon. However, I love my X1 and the Lumin app works great so at least I can still listen to my library :wink:

I just tried the steps that were posted earlier in the thread to delete some Roon’s registration/preference files. It did not improve the situation with the failed update to Roon 1.8 on macOS. Oh well, it was worth a try!

I tried the steps described in Read this if "There was an issue loading your database" after updating to Build 880, again without success. Even the oldest backup in available (~5 weeks) ends up with a corrupted database message.

I am now starting from scratch with my library, rescanning everything. This is not great and as a paying customer, well, I’m wondering what it is I’m paying for if I have to spent a couple hours to debug and eventually start from scratch with my library. I would appreciate some thoughts from the Roon team on this point. For bonus points, maybe you can publish a post-mortem as this seems to affect a number of people.


Hey @schuroo,

Thank you for doing all that you could have to remedy this situation. We appreciate you keeping up on community, trying the steps we suggested and talking to us about it. We’re grateful.

Also, there is no good way to frame this, and the reality is, there is hardly anything we can do to restore a database that Roon detects is corrupt.

The only silver lining I see is knowing that this updates brought integrity checks that will help us never live through this scenario again. The moment corruption is identified, you will be notified and restoring a previous backup will resolve it.

1 Like

It seems one way to restore the working status quo from before is to roll back the breaking changes introduced with the update (basically go back to the previous version) and allow everyone to load backups that worked with the previous version.
You could possibly enable such behavior by flag-guarding new features or potentially breaking changes which would allow users to take these steps themselves without you having to push new releases. Food for thought …

Anyway, I’m now in the process of starting from scratch and invest the time there as I already sunk enough time into attempts of restoring what I had before.


Hey @schuroo,

I can see how, from where you stand, downgrading would be a solution. There are a few reasons why we think that doesn’t help:

Actually reading this link makes me cringe:

"Database Incompatibility

As each version of Roon is released, the internal composition of the database changes, as new functionality is added, and old functionality is migrated into new formats, or deprecated. Our team does extensive testing to ensure these changes are safe and stable, so that each new version of Roon installs smoothly across our entire customer base, whether they started using Roon last week, or years ago.

This testing ensures older databases migrate successfully to the new format, and occasionally we do find issues during this testing that we make sure are resolved before the release goes live.
Not only is no comparable testing is done for the “downgrading” process, there is no migration procedure in place for moving back in time. Database changes can happen on both “minor” and “major” releases, and in general. If you load a current database with an older version of Roon, it can cause Roon to fail to load, or in some cases can actually corrupt the database.
If you corrupt your database by downgrading, we will not be able to help."

But if you corrupt your database by upgrading, you’re on your own!

1 Like

Hey everyone,

Thanks for keeping the conversation going and bringing all these points to the table. Please know our team is active on community, reading all the posts and taking them into account. We appreciate you sharing your thoughts :pray:

In the meantime, I wonder if you’ve seen our latest staff post?

We’ll post all other updates here.

After giving up on migration I started from scratch with 880 yesterday. It was working and I could listen to Christmas music again. Today, the 882 build was pushed and I am back to DB errors. Client-side it just says There was an issue loading your database. Server-side, I see the following in the logs:

2/18 17:00:10 Critical: Library.EndMutation: System.ArgumentException: String contains invalid Unicode code points. (Parameter 'strInput')
   at System.Globalization.Normalization.ValidateArguments(String strInput, NormalizationForm normalizationForm)
   at System.Globalization.Normalization.IcuNormalize(String strInput, NormalizationForm normalizationForm)
   at System.Globalization.Normalization.Normalize(String strInput, NormalizationForm normalizationForm)
   at System.String.Normalize(NormalizationForm normalizationForm)
   at Sooloos.KeyNameHelper.DefaultFilterKey(String name, Boolean normalize)
   at Sooloos.Broker.Music.LibraryPerformer._Load(LibraryMutationEnv env, PerformerLiteData performer)
   at Sooloos.Broker.Music.LibraryPerformer..ctor(LibraryMutationEnv env, PerformerLiteData performer)
   at Sooloos.Broker.Music.Library._GetPerformerByIdUnmapped(Int64 performerid, Boolean quiet)
   at Sooloos.Broker.Music.Library.GetPerformerById(Int64 performerid, Boolean quiet, Boolean require_has_references)
   at Sooloos.Broker.Music.LibraryAlbum._LoadMainPerformers(LibraryMutationEnv env)
   at Sooloos.Broker.Music.LibraryAlbum._Load(LibraryMutationEnv env, AlbumLiteData album)
   at Sooloos.Broker.Music.LibraryAlbum..ctor(LibraryMutationEnv env, AlbumLiteData album)
   at Sooloos.Broker.Music.Library.GetAlbumById(Int64 albumid, Boolean quiet, Boolean require_has_references)
   at Sooloos.Broker.Music.Library._ProcessClump(IEnumerable`1 etracks, String clump_scheme, Dictionary`2 tracks_to_load, ILookup`2 auxfiles_by_dir, Nullable`1 strategy)
   at Sooloos.Broker.Music.Library.PerformStorageBackendClumping(IList`1 input_tracks, Dictionary`2 tracks_to_load, IList`1 input_auxfiles, Dictionary`2 auxfiles_to_load)
   at Sooloos.Broker.Music.Library.PerformClumping(IEnumerable`1 input_tracks, Dictionary`2 tracks_to_load, IEnumerable`1 input_auxfiles, Dictionary`2 auxfiles_to_load)
   at Sooloos.Broker.Music.LibraryMutationEnv.Finish()
   at Sooloos.Broker.Music.Library.EndMutation()
12/18 17:00:10 Trace: [library] endmutation in 1975ms

As a paying customer, I’m getting tired of chasing bugs …

To add one more data point. The machine running RoonServer restarted today and afterwards Roon showed 0 tracks again and 0 audio devices. I replayed a backup ( through the UI) created with the 882 build yesterday when it was working, but now I’m back again at There was an issue loading your database.

The server logs show the same error message I already posted above (Critical: Library.EndMutation: System.ArgumentException: String contains invalid Unicode code points.).

Hey @schuroo,

I’m so sorry that I didn’t get a chance to reply to your post until today…I do hope your holidays have been beautiful and hopefully with music :crossed_fingers:

I wanted to follow up and see if Roon is in the same state as it was about two weeks ago?

Thanks for asking, appreciated.

After the 884 update I did not experience any further instances of the issues I described above. So at the moment, all is good thanks.

Thanks for asking and thanks for providing a patch before the holidays.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.