Delays when controlling Matrix Element X device volume from Roon UI

Core Machine (Operating system/System info/Roon build number)
Mac Mini 2011, core i7, 8G RAM, OS X 10.11.4, Roon 1.7.667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Asus RT-AX88U router, core machine and audio devices connected via Ethernet using Netgear GS 205 switch, Cat 6 cables. Control devices like iPad/Mac book connected via 5ghz wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Matrix Element X, connected via Ethernet.

Description Of Issue
I have random issue when trying to control Matrix Element X device volume from Roon UI - most time it’s fine, but sometimes it reacts on ± buttons or slider with delay, or doesn’t react at all. It usually happens in the beginning of new track.

I contacted Matrix Audio support, but they were not able to reproduce this. So I suspect that this is my specific setup issue and need a help resolving this.
CPU usage on core machine is quite low, while I’m using PEQ and volume leveling, the issue is also reproducible without any DSP processing.

Tried also to switch everything directly to router - same issue.

I also checked Roon logs for errors, didn’t find anything except this:

11/14 12:08:25 Error: Error in thread pool work item: OpenHome.Net.ControlPoint.ProxyError: 1:Unknown
  at OpenHome.Net.ControlPoint.Proxies.CpProxyLinnCoUkVolkano1.SyncProductId (System.String& aProductNumber) [0x00027] in <26f3e282cbaa4f50bcdd636cbf6fe893>:0 
  at Sooloos.Broker.Transport.SongcastDirectDevice+<>c__DisplayClass79_0.<Initialize>b__1 (Sooloos.CallingThread _) [0x0000d] in <26f3e282cbaa4f50bcdd636cbf6fe893>:0 
  at Sooloos.CallingThread+<>c__DisplayClass10_0.<DoThreadPoolWork>b__0 (System.Object <p0>) [0x00000] in <f7e3dd0e530745e3ad2cdb5d1f21ff79>:0

I just found a semi-reliable way to reproduce issue:

  1. Start playing some track in Roon
  2. Pause playback
  3. Start playing another track
  4. Try to change volume immediately from Roon with single pressing of ± buttons - volume changes with a delay

I also tried to setup a new core on my Mac book Pro (8 cores, 32 Gb RAM) - same issue. So it doesn’t depend on hardware.

Sorry to ask, but have you rebooted the device?

Sure, many times

Hello @vladimirkl, could you reproduce the issue one more time using the steps above and reply here with a timestamp (in your local time) when you do? I’d like to enable diagnostics for your account and gather some data, thanks!

Hi @nuwriy, I just reproduced volume delay two times - today, 11/17 at 16:51 and 16:52 local time.

Hello @vladimirkl,
I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

@nuwriy My core is aways active since 11/17, does it mean that report is already uploaded? Or it is still missing and I have to reproduce once more?

Hello @vladimirkl, looks like the report uploaded, so I’m creating your ticket for the team now. I’ll return once I have their feedback.

Hello @vladimirkl,

We reached out to Matrix Audio about this, they informed us that they’re investigating and hope to make some improvements in this area in an upcoming firmware update.


Thank you very much!

I notice the same on my Matrix Audio Element X device, suspect this is a device issue, and not connected to Roon - delay is not big, but it is there (don’t have similar “issue” with my Trinnov Altitude32). So report this to Matrix Audio.

I already reported - they answered that they cannot reproduce. This is ridiculous as issue is very easy to encounter with normal usage. Unfortunately many people complain about quality of Matrix Audio support.

Seems to work fine here now, new app for iOS and Android + new firmware for the Element X.

Did you upgrade the firmware using the iOS app? Any problems? Thanks.

Just did it. Very slick and painless.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.