Deleted an album in Roon, can't restore it

I have seen some posts on this issue but nowwhere the solution to my problem.
I deleted an album in Roon. It is stored on my Synology NAS.
I want to restore the album in my library and already did the following:

  1. deleted the map from my NAS
  2. rescanned my library
  3. turned off- and on the Core
  4. deleted my library-map and restored it from backup
  5. restored the album in my library again

Nothing Works! Very frustrating and I am out of options. Anyone an idea?

Kind regards,

When you delete an album it is removed from the storage location too. There are multiple warnings to this affect. Therefore, your only route is to recover the deleted album from your backup.

1 Like

It was not deleted from my NAS. It just does not show up in my library anymore. I deleted it from my NAS, cleared cache, cleaned library, restored the album and still it does not show.

Does Roon see the album if you copy it to the local storage on your core?

Did you delete the album in Roon? If so, it deletes the file too.

If you’ve put back the file from backup already, after Settings > Library > Cleanup Library, reboot the Core and then try Settings > Storage > Force Rescan.

Already wrote that, but thanks for thinking with me.

No, it does not see anything :frowning:

In which case I’m baffled, maybe @support can advise.

That’s the problem … you say you “Deleted an album in Roon” but “It was not deleted from my NAS.” So, it is unclear what you’ve done. Nonetheless, I have tried to cover the bases. Did you follow the steps exactly?

Yes Martin, just did all the steps for the second time. Without any result. Very strange.
Maybe it has to do something with cache (although I cleared that as well in Roon)…

Thanks for helping me out. I solved this problem by deleting all versions of the album on locations (downloads, library, trash). Then rebooted my NAS and external SSD (core). Then downloaded the album again and now it appears again in my Roon library. Still don’t understand it but the problem is solved. Thanks again!
Kind regards,