Deleted Tidal album but cannot add own CD version to ROON library anymore

I wanted to replace an album that I added from Tidal with the CD version I bought.
So I deleted the Tidal version from my library in ROON. But now ROON does not show the CD version, although it is saved in the local directory, which is scanned by ROON.

When I search in ROON for that album, I can only find the Tidal version, but not the version that is physically located in the scanned directory structure.

Any idea how to get the local version “back” into ROON after deleting the Tidal version?

If I had this problem I would do the following:

  1. Settings > Library click Clean up library.

  2. Then go to Settings > Storage and force a rescan and see if it detects the change.

Or, drag the folder of the album out of the directory then do step one. Then drop the album back in the folder of the library and roon should detect the change.

Thanks ffk,

I did this already and it didn’t help. Is there a way to directly access and query the ROON library (e.g. via some SQL queries) to analyse what ROON is having in the database?
Or could I see somewhere happens during the scan? I would expect some message their, why the CD album is not included into the library.

Have you checked skipped files section above the maintenance button?

Chris this is something I have done multiple times in the last week (Roon on Rock on internal hd for context).
Each time it album has appeared within seconds of arriving into the folder that Roon is scanning.

I am assuming you have already done this but try updating the Metadata in place and update the timestamp on the files.

Other than that it sounds like it is something on your system.

Other option, re-add to Tidal and then see if you find the local copy in versions.

the files were listed as “Audio stream format not supported” in the “Settings/Library/Skipped files” section. These files came directly from the label (Concord Records) delivered with an USB stick album in WAV format. I converted the WAV files to ALAC and added it to my music storage.
I first tried it with the original WAV files and they were showing up in ROON. Now I reconverted the files to ALAC with the actual version of XLD tool and no problem with these version.

There was one more hick-up. I wanted to delete the TIDAL version again, that I re-added this morning to test whether this has something to do with it. It did not work (“No items selected” was given when clicking on the “delete from library” in the TIDAL album).
Cleaning up library function called, same problem.
Stopped ROON and started it again - et voila, now the “delete from library” worked.

So thanks for the support to everybody.

I would suggest going to the album view, sorting by album name, and see if the album shows up that way. If it does, click on the album, search for “versions”, and set this as the primary version. If the Tidal version shows, delete it. If any part of the Tidal version is on a playlist, it would now show as unavailable, but may also still be listed as the primary version. I, on rare occasions, have had this happen to me.