Denafrips Ares 2 not recognised with RopieeXL + pi 4B

there’s no volume control on the ARES 2 DAC. I’m using a preamp for that.

No, I haven’t tried the XL version as Harry has stated the code base is exactly the same between the two.
As for the USB update, I recall applying that back when I was using a RPi3. I don’t think it applies to the RPi4 (either way, I don’t see the option to update in the settings).

Since the NUC also had trouble with the USB input of the Ares II, I’m beginning to wonder if the problem is with the Ares and not Ropieee.

True, however I did experience differences between the 2 versions. I’m running XL. If you go to generic info you will see USB FW version and a update button

There are no differences. Really.

If you’re doing RAAT only (= Roon) then stick with regular RoPieee. There is not a single reason in that case to go for XL.

The FW update for the USB controller is Pi4 only. It is not applicable for the Pi < 4.

My RPi 4 rev 1.2 doesn’t show the update button at all, while my second RPi4 rev 1.1 (which is the one I’m having this trouble with) shows the update button but is grayed out. I’m pretty sure I already applied it.
As for the RPi 3 USB update I did that separately while running Raspian on the same pi.

Hmm, I wonder if I should try moving the RPi4 rev 1.2 to the Ares DAC. Maybe the newer rev level will resolve this issue?

@spockfish Can I just swap out the microSD cards between the two Rpi4’s

I would not do that. For sure you will run into issues.

Thanks. I’ll just rename them and swap’em

Hi Harry, Earlier In this post I have written down my experience with the Ropieee software and while it doesn’t make sense to start a discussion with the person who wrote the software :slight_smile: I did see differences on the Ares 2 . I’m using XL on 2x pi 4 and I’m really happy with the performance. Good job !

After latest update, my Allo USBridge Sig running RopieeXL can not recognize Denefrips Ares II. Anyone else has the same problem? It has been working fine till the latest ROpieeeXL update. Thanks!

Which update are you referring to? The latest Ropieee update or the recent Roon Labs update to ver 1.8?

I’m using a RPi4 (not the Allo USBridge) with ver3.075 and am not experiencing any issues with my Ares II.

I recently applied the Roon Labs 1.8 update to my server & tablets/phones. I had reboot the tablets and the phone to get the new app to function normally. Have you rebooted the Allo USBridge?

Thanks [Thomas_Prossima1]! You are right, I forgot that Roon Core on my Synology server was also updated to 1.8 yesterday. It seems the problem was caused by Roon 1.8. I switched RopieeeXL to Moode, I was able to play music files stored on a USB plugged into Allo USBridge Signature directly. Then I installed Roon Bridge through Moode, but still was not able to find the Denafrips DAC in Roon. After reading your response, I rebooted Roon core, the DAC was showing in Roon/Setting/Audio again. Since then it disappeared two more times, and each time I could restore by rebooting Roon core…

Interestingly, after posting my reply I also had issues with Roon not detecting Ropieee attached DAC’s. In my case it wasn’t my Ares II DAC, but the DAC on a HD-Amp1 Marantz amp being fed by a RPi4 (via USB). I had to reboot the NUC that’s running Roon Rock to be able to get it to appear again. It’s been 24hrs and so far it’s still working normally after the reboot.

Just to let people know that there’s a freeware alternative for Ropiee available.
No intention to talk negative about Ropieee nor to pick sides !
Just sharing information, if people want to give it a try.

see john Darko’s website

Thanks for the info. But my Allo USBridge Sig is based on rpi3, so I am not sure it would be able to run VitOS… I have tried dietpi, ropieeeXL and moode so far, liked moode better in terms of SQ…

It’s mentioned to work on the Pi 4, therefore I presume it will not work for your Pi 3 but you can give it a try ? I have switched from Ropieee to VitOs as It was to often that my Ares 2 DAC was not recognised by Roon. Now with VItOs so far ( knock wood) it’s stable.
Not saying it’s Ropieee to blame. The mix of Ares 2 and Ropieee is just not a good marriage it seems


@Sean921 can you send me feedback? You can find that option on the ‘advanced’ tab.


Advanced tab in RopieeeXL?

Yes that’s the one.

I’m purchasing a Denafrips Ares II. As a streamer I’m thinking of a RPi 4 connected via usb, running Ropieee XL. Could I have some issues on Roon? Thanks