Denafrips Ares 2 not recognised with RopieeXL + pi 4B

I have bought myself a Raspberry Pi 4B and installed RoPieee XL on it.
When connecting the USB output to my Schiit Modi DAC everything goes via the book.
However when switching over to my Denafrips Ares 2 DAC that DAC stays invisible.
Disconnecting the USB cable from the ares 2 and putting it into the make the modi DAC come to life within a second.
Anyone ? any thought why the Denafrips ares 2 isn’t recognised ?
I have powered down the raspberry and the DAC a few times but that didn’t make a difference.

My current setup is a Aries Mini ( as bridge) connected with the Ares 2 ( the DAC) via USB. That works fine. I now want to compare bridges. Aries mini vs Raspberry PI perhaps there’s something to gain sound wise ?

Thanks for your help

Interesting. I would have thought the Ares II would have worked with the RPi. I have an Ares II connected via USB to my ROCK installed on an Intel NUC and it works.

I’ll check mine (on trial now) with a RPi 3b and 4b but it’s running fine on microrendu now, when I get a minute.

Edit update…working fine here

Note Ares II must be on and set to USB to be seen

I did not do any firmware upgrade. it’s native out of the box. I read something about USB upgrade but for the moment left it untouched.
Are you using RopieeXL ? perhaps that could be a difference ?

Hi Hans,

It does not make a difference whether you use the normal one or XL. They share the same base.

Can you verify the USB controller firmware? You can find that on the ‘info’ page on RoPieee’s webpage. If there’s an update available the ‘update’ button is activated.

Furthermore, can you send me feedback so I can have a better look? You can find that option on the ‘advanced’ tab. Please do that with the DAC connected and powered on.


hi Harry,

Thanks for helping me out.
I’m traveling this week so please accept a delay getting this info back to you.

Thanks for our support !

1 Like

Hi Hans,

Problem solved after I have updated the USB FW version in Ropiee.
For it still could be interesting for you to look into the log ? I have send you 2 log files
log 1 before the update of the USB FW version. Log: adbdbf77bc7f2346
log 2 after the update. Log: 59609a50e46499

Thanks !

Hi @Hans_Bogaert

Good to hear! In the next RoPieee version this firmware is also present.
I’m not surprised tbh, because I saw in the logs of the firmware remarks about USB sync stuff.

Thanks for the logs!

I’ve bought a second raspberry pi 4b and installed on it the latest version of Ropieexl
Strangely enough both my Schiit and Denafrips dac were not recognised (USB)
My other Raspberry with the same software and USB version working fine.
For test purpose I’ve took out that Sd card out and put that in the pi that with issues.
The effect was that Airplay was now recognised but nothing more
Putting the SD back back in the original pi had a negative impact.
where previous that pi was working 100% now mu Schiit dac was no longer visible.
Somehow moving the SD card over from one pi to the other had a negative impact.
I’ve again installed the RoPieee software but that didn’t make a difference.
I’m stuck, any thoughts ?
All in all I now have 1 pi that recognised my Denafrips dac while not recognise my Schiit DAC besides the airplay over USB mode for that DAC
the other PI does not recognise anything via USB
i’ve uploaded some info

You can’t swap cards once installation is completed so you will have to reflash the card to run in another RPi. Always safest to flash and install and leave it in that pri for good.

1 Like

I was not aware of that, but when after moving the SD card back and some functionality was lost It had to be a change in the config.
I still wonder why the USB connection is so sensitive.
I now have 2 raspberry pi’s that are identical according to the spec.
They are running the same software version of Ropieexl and have the same USB firmware version, but the USB interaction with my DACs is not alike.

Maybe you need to reflash both micro SD cards with the same version of RoPieee or RoPieeeXL. If they are identical devices and set up the same, they will act the same. I have built 3 of these and they are the same.

Always build a new card image with a new RPi - there are im sure subtle differences especially adding HAT’s and while I have swapped USB DAC’s around on some of my units even though its not caused any issues maybe I have just been lucky.

comparing the Ropiee settings of both pi’s they show up as 100% identical.
Identical in both hardware and software.
Even the USB driver is updated to the same version.
When I bought my first Pi I had an issue as my new bought Ares 2 didn’t show up.
Harry vd Berg send me a driver update and after that it worked flawless.
Being convinced that this was a good route to go I bought my second PI.
I’m now hesitating to reinstall firmware on the one Pi that does recognises my ARES 2.
What if it doesn’t work ?

Few remarks.

If you only do RAAT then please use RoPieee instead of XL. Makes debugging on my side a little easier :wink:

Secondly it’s unclear what exact the problem is. So I suggest you install an image from scratch and we’ll figure it out from there.

There’s a kernel update (the OS used by RoPieee) that addresses a few USB issues on other devices, so it might well be that it fixes the issue with your DAC as well.

Harry, Let me recap to get the problem clear :slight_smile:

I have a pi model 4B that’ s working fine. In the past I installed version 20200216 together with a USB firmware update and Recently I’ve updated that Pi to version 2020317 and it’s still running fine.
It can see both my USB DAC’s ( Denafrips ARES 2 and Schiit Modi multibit )

I’ve now bought a second Pi. and installed directly version 2020317 as that is available on the website.
That version however doesn’t recognise my DAC’s.
I have gone over the installation process a few times and experimented with the standard and the XL version.

Something new !
I looked in my download folder and found version 20200216. (XL)
I’ve installed that version again and now both my DAC are recognised.

Conclusion. If I install directly version 20200317 both my DAC’s are invisible.
When I install version 20200216 they show up and upgrading to 20200317 has no negative impact.
Hope this info helps

I’ve started to experiment with my pi that was working fine to see what happens if I do a fresh install.
I conclude, I have to start with version 20200216 for all attempts with version 2020317 were no success.
Next to that, I also have to install the new firmware while the ethernet cable is connected.
If I install the new firmware without the internet connectional ( my DAC’s are not detected) and whatever route i take next. it does not lead to success ( my days are visable)

Just consider the Ares II as new dac and also using Rock/NUC.
Are you able to use volume control from eg. a remote like Ipad?

I’m curious Hans, are you using the USB 2 or USB 3 ports on the RPi4?

I’ve never had a problem with Ropieee recognizing the Ares II. But I do have a problem with Ropieee intermittently losing the USB connection. I get random dropouts - each lasting about a second. I’m using the current version of the standard Ropieee.
All this time I have been using the USB 2 ports. I just switched them over to the USB 3 ports. It’s still too soon to know if that made any difference or not.

As a side note I used to have the Ares II connected to my Intel NUC running Rock over USB. With that particular setup the NUC would randomly not see the Ares II after several days or so. I would have to reboot the NUC to re-establish the connection.

Hi Thomas,

I haven’t had that experience. My only issue was that the ARES 2 DAC wasn’t recognised.
that’s all gone now ands its running stable. Strange that it’s losing the connection. Have you tried to switch between the 2 version of Ropiee ? there’s a light version and a full version.
BTW there’s an update for the USB driver in Ropiee. ( you can see that in the settings )have you tried that ?