Devialet Expert Pro 140 not playing nice with Roon

I have a Roon Nucleus as my core, connected via the network (ethernet) to a Devialet Expert Pro 140. The Devialet is connected to the network with ethernet, and WiFi is enabled in the config settings. I use the Roon app on either my mobile devices (Apple iPad/iPhone) or from my desktop/laptop (Apple iMac/Air) to select and play music from my database and Tidal.

Sometimes, when I press “Play” in the app, the Dev obediently fires up, switches to “Air” and works fine, BUT about half the time, after a pause, I get a message on the App saying “Audio device refused to switch input to Roon”, and the Dev fails to power up or play anything.

Any ideas?

Ethernet is know to cause problems with Roon and Export Pro. Unplug the ethernet and use WiFi. Configure the Devialet as a Roon Ready device in Roon. Also make sure you have the latest firmware.

When I fire up my Devialet 440 Pro via roon, the amp automatically switches to the roon ready input. I think you might have a configuration problem in roon. Check that you have the roon ready settings correctly configured as @frankg says. As you have Ethernet connectivity, forget about using wi-fi, it can be a bit flaky. Some people have had problems using a gigabit connection between roon and Devialet, some haven’t. The workaround is to use a megabit switch somewhere in the chain. Please see attached image. The item circled in red should be enabled. I think you might have one of the items circled in blue enabled, so try disabling these. image|690x466

Hope this helps.

Try Devialet AIR device, instead of Roon RAAT.

Did you get this resolved?
I think you need to disable the network interface you’re not using in your 140. Try disabling wifi (in configurator) first. Wifi on the Dev is not necessary to control anything and may confuse your 140 into trying wifi even if there is no audio stream present.
If the connection on ethernet is not stable, try it the other way around. Remember to make changes in Roon accordingly if you switch.
The third option is to connect the 140 ethernet to a 100mbps interface. There was (is) a bug where the Gig port on the Devialet would stop receiving the stream from Roon. The workaround was connecting the Dev to a 100mbps port. I am unsure if this bug has been fixed completely.

Unplug your Devialet for a few minutes. Sometimes this will do the trick.

Hi Frank,
I got some feedback saying disconnect ethernet and others saying disconnect WiFi, but either way, I get the sense that having both configured is a no no, so I’ll start by trying ethernet alone, then the other way if I still have issues.
But… What do you and others mean by “configure the Devialet as Roon Ready device in Roon”? I can’t see anything in the Roon settings for the Devialet that alters its network connection/connectivity/status. See attached screenshot of the Audio page, and the next screenshot of the Device setup page for the Devialet. Nothing to do with networking.
I do note that the Devialet is listed as being connected via Air and an IP address is given, but it’s not clear whether these are two separate network connections (the ethernet cable is still in at this point).

Hi ogs.
Thanks for this feedback. See my reply to Frank’s posting. I’ll try hard wired alone first, the WiFi alone if no go.
But again, what do you mean by “Remember to make changes in Roon accordingly…”? Where do I make these changes?

Hi Axel,
Just BTW, how do you “fire up your Dev via Roon”. Just by pressing “Play” with the Dev selected as the Zone?
Also, my Dev shows up as Roon Tested (see pic in my reply to Frank), not Roon Ready. Any idea why this might be? And can it be changed (see my questions about configuring the Devialet in Roon).

Hi Peter,
What version of firmware is your Devialet running?

Have you set the buffering in the Device setup to anything between 50-100 milliseconds? If by chance you leave it at 0 millisecond, I almost always get problems, regardless whether Ethernet or USB-connected.

Do you have the CI board installed? Because that makes your Pro using the RAAT protocol and I don’t understand why it should switch to the AIR protocol.

Do you get the same problem when using USB?

Hi Peter,

Yes, exactly that. With my Devialet as a roon ready device, all I need to do is to choose a piece of music or radio station, press play and the Devialet turns on , switches to the roon ready input and plays the music.

If you are running the Air software on your Mac, delete it. When you are using the Ethernet connection (which is the best bet as it will be the most stable) you don’t need Air and I’ve heard of situations where Air running can cause problems. As @ogs mentioned above, turn off wi-fi in the configurator.

AFAIK when roon detects the roon ready Devialet on the LAN it will give the option to enable it.

Hope you get this sorted out soon, I’m sure it just needs a bit of tweaking.

Edit: there have been problems editing existing Devialet configurations. You are better off starting from scratch, even to the extent of creating an “anonymous” config.

Cheers,
Alex.

Roon will see ethernet and wifi as separate connections. Just make sure to enable and configure under Settings-> Audio

Hi Frank
It was on 13.1.1, so I upgraded to 13.2.

Then I tried it with just the Ethernet connection (no wifi in config file). This “worked”, but the Dev was still using “Air” as the source, and still showing as “Roon Tested” (not Roon Ready) in Roon, AND, without wifi, I can’t stream to the Devialet via Airplay from any other app (like Apple Music or Spotify), so it was less than ideal.

Then I switched to WiFi only (revised config file and unplugged the ethernet cable). This has fixed it completely (so far)! The Dev is using the “Roon Ready” source, and shows up as such in the Roon app. Hopefully, this will stick!

One last note, in response to Paul’s comment re buffering delay, I set this at 100ms too, just in case.

Thanks everyone for your help so far. If anyone has any further feedback for me re my questions about configuring the Dev in the Roon app, please feel free to reply to my post.
Peter

Thanks Alex.
I wasn’t running Air on the Mac, but the Dev kept show Air as the source (on its front panel), and Roon itself never recognised the Dev as “Roon Ready”, just Roon Tested.

As noted in my reply to Frank, I got rid of the WiFi connection first, but it didn’t fix the issue, so I went to WiFi only, and everything’s working as advertised. The Dev is playing from Roon Ready as the source, and Roon itself reflects that. Fingers crossed.
Peter

As you saw ogs, Roon never saw the Dev as Roon Ready when it had an ethernet connection, so that’s why I was struggling to follow your comments. Nothing was Roon Ready under Settings/Audio…

All resolved once I went WiFi only though, so again thanks for your help. Very much appreciated.
Peter

You’re welcome, Peter. Glad you got it sorted.

Thanks for this input Paul.
Once I solved the primary problem, I set this at 100ms on the basis of your feedback. No problems with either setting, but I’ll leave it delayed that little bit ust as a precaution.

And yes, I do have the CI board, and No, I’ve not tried connecting the Nucleus to the Dev with USB.
Given that the Dev should be using RAAT rather than Air, I don’t know why it showed Air as the source when ethernet was connected… A mystery, but resolved now with a WiFi only connection.
Peter