Dietpi can not install ROON extension

Hi group, anyone know how to fix this?

I have upload a bug report to Dietpi.

Are you installing the Extension Manager as part of the initial DietPi setup process?

If so, then the first thing to try is to deselect the Extension Manager installation and first perform a reboot. After the reboot login as the root user and then install the Extension Manager.

If the same error occurs again then please select Open subshell and provide me the output of the following command:

systemctl status docker.service

thanks it works. problem solved


Have had DietPi software install errors as well.
What it fails at is downloading some install scripts from MichaIng’s GitHub - can take dozens of retries until it finally resolves.

Indeed it’s an issue when Docker is installed after a kernel upgrade without a reboot. Installed kernel modules and loaded kernel then do not match, leading to the Docker failure. A reboot then allows to install it and hence Roon Extension Manager.

If Docker is selected explicitly and the kernel mismatch is detected, is is detected with a related info already, but if it gets pulled in as dependency only (i.e. if only Roon Extension Manager was selected) the check is not done. We’ll fix this with next DietPi version.