Dietpi+RPI3 B+ +Roon Extension + Chromium display issue


(Taeksun Shin) #1

Hi…

I tried to install DietPi + Roon entension + Chromium kiosk on my RPI3 B+…and 7in touch screen.

and I read and search the article many times. I succeeded all process, but when I finished all process,
I just can see the command line on my 7 inch touch Screen.
I re-installed over 10 times, but all the same situation.

Anybody know How I could send the web control interface to show on touch Screen?
I think that it is the problem of Autostart script, because Chromium didn’t start to show when dietpi started…


(Bart Maguire) #2

I have the same problem, the dietpi-autostart_service is not running and I can’t see how to force it


(Taeksun Shin) #5

Hello… Bart…

First of all, I am a beginner to handle the program. But In case of me, I got a small solution… I coiuldn’t sleep for a few days… haha
1.Connect to SSH to dietpi
2.Type> sudo nano /etc/profile
Go to bottom line then, type
startx – -nocursor
Crtl+exit > Y ‘save’
3.Type> dietpi-autostart
I changed Autostart option to Auto log-in with command line
(Maybe 1 or 2)
3.Reboot
dietpi will auto log-in then start script startx for kiosk mode automatically.

I refer that site,
https://www.opentechguides.com/how-to/article/raspberry-pi/5/raspberry-pi-auto-start.html 1
https://die-antwort.eu/techblog/2017-12-setup-raspberry-pi-for-kiosk-mode/

Sorry for my poor English and hope this to helpful for you


(Bart Maguire) #6

Hi, thanks for that but it did not solve the problem.
I have another SD card with DietPi and the Roon Web Controller on it and it has also stopped displaying on the hardware. Both images used to work and nothing has changed here.
I am going to re-flash one and see if it fixes it.


(Bart Maguire) #7

@mike_plugge
I had the Roon-Web-Controller extension installed and working on a Raspberry Pi with the official 7" touchscreen.
Some weeks later, when I booted it up again it wasn’t working. I reflashed the SD card and followed the instructions to install everything (including making the scripts executable) but it did not work. On boot it sits at the login prompt. If I log in and run the custom startup script then it works.
If I run systemctl I see that dietpi-autostart_service is not running. I have enabled it but this does not survive a reboot.
A couple of days ago I flashed a new SD card and repeated the process, with the same result. The Roon-Web-Controller will run if I start the service or run the custom script manually, but does not start automatically on reboot.