Disable ARC in the roon core [not on roadmap, but you can disable the UPnP punch by entering port 0]

Please make button in the settings to enable/disable the ARC functions and let users decide if the want a hole in there firewall. and look at more secure ways to connect to the core an open port is never the solution

sincerely
Marco van Leeuwen

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

3 Likes

Put a ‘0’ in the port box in the arc settings to disable arc.

1 Like

That seems to work. it does not perform connection diagnostics, but the next time you open Roon it selects a different random port instead of showing port 0

It doesn’t disable ARC, it just disables port forwarding. Roon ARC will still work on the local network. Good enough for what the OP is requesting though.

Indeed. Sorry I should’ve been more clear. Thank you. :slightly_smiling_face:

If a user has no need for ARC, it would be useful to be able to disable that portion of the software. I would prefer to have a toggle button for this.

2 Likes

I moved this to feature suggestions as it’s not truly a support issue so please remember to cast a vote for it at the top.

1 Like

@support
I do not want to use Roon Arc, so I have put in “0” as port-number in the Roon Arc-settings.
But when I close the Roon App and I go back to Settings - Roon Arc, a new vallid portnumber has been set. The “0” has disappeared.
So how can I make the “0” persistent?

1 Like

Hi @Frank_M,

A couple of things.

  1. I didn’t know putting a zero in the Roon Arc section of Roon would revert back to 55000. That’s good information so thank you.

  2. It’s not a concern. If you haven’t changed any settings on your router or firewall, Roon is simply listening should someone knock so to speak. Until those changes are made, Arc communications are not getting through from the outside to your network.

Perhaps we will provide an actual toggle switch in the future but I wanted to address your concern.

Wes

4 Likes

Thanks for this suggestion and workaround. Was shocked to have this dropped in my install. And then infuriated to find it was not allowed to disable. I have it blocked at the firewall but exceedingly poorly done by Roon. Such a feature is to be disabled by default and only enabled when a customer turns it on. In this age of automated cybersecurity attacks and supply-chain compromise (see not-Petya as example) this adds a hole into any network, no matter the assurances of Roon developers. Seriously. Poorly done. Please fix.

3 Likes

You should be complaining to every WiFi/consumer router maker out there that has UPnP on by default, not Roon. Roon is simply utilizing UPnP as it was intended to be, as are a lot of other software developers out there.

2 Likes

May be true but Roon should have given then option to not have it enabled at all.

2 Likes

This post was flagged by the community and is temporarily hidden.

Hello all,

I would like to deactivate the function together with the constant Internet access.
ARC active = constant internet connection required.
ARC inactive = no internet connection required.
My connection is often unstable and going back to 1.8 is too much work for me.
Thanks and regards

1 Like

Hi @Angelo_Spampinato,

1.8 legacy won’t always be supported but you can certainly downgrade. ARC isn’t the only reason for the constant internet access, Roon 2.0 requires it whether you use ARC or not. It’s an architecture change that is necessary to continue the development and support of new features.

Here’s the guide to downgrade to legacy:

Wes

Hi,
its not a problem that the Roon core or ARC makes a internet connection everybody will understand that if you want the extra content Roon needs some place to get it. But it is a problem if you bring me my new player and drill a hole in my front door without asking. Some people like me don’t like to have open ports and programs that are listening on that ports, especially if the don’t want to use Roon outside there network. i have Upnp disabled on all the firewalls, so i got only the error message (also not nice). and yes, i got immediately the solution to put 0 by the port but after reenter there was a different port number.
but be honest it was muts more gracefully if there was a slider button that enable or disable the upnp and if disabled the port section grey-out and shows no port number. that can’t be more than 10 minutes of programming it is only a “if then” function .

marco

so why do you care? nothing affects you here. Roon does nothing in this case.

Because i advised Roon to my friends and family and guess who can help them if there are troubles.
And i can run my network but my wife not, so if something happens to me our company ends and the network will be down graded to a consumer grade network. And then it would be nice that she can have all the familiar programs without having to worry about network security.
And don’t get me wrong Upnp is great for programs that need a short time an open port but roon core stays on 24/7. I have here also a polycon video system that needs open port to get calls. but after 5 minutes when the system is powered on it becomes very busy on the wan side, so busy that normal internet traffic was not longer possible. i moved it between two firewalls and have scripts in place that closes the ports if the polycon comes unavailable.
It’s always a good idea to let users decide if the want the extra risk to get the outdoor functionality.