Disable multi-part grouping on ALL albums

I have a large number of albums (both local FLAC and tidal) that Roon has decided are multi-part compositions. I know how to disable this per-album, but as I have 500 albums (not many by most standards) this is not remotely practical. How can I make disabled the default? (I’m ok with the feature not existing at all, but I’m also happy to manually enable it if I ever find a single album it’s useful for, at the moment it has only served to break all my playlists and shuffling.

you can set preference for all albums:

I just tried it, and it seems to work. (Unfortunately, it now takes quite some time now with my library to restore it to the default ‘Roon’ choice, which I prefer)

Dirk

Hi Dirk, trying that metadata preference setting has made no change on any of the albums I’ve tested it on (I think because it’s interpreting based on file-name metadata). The only setting that seems to turn it off entirely is “disable multipart grouping” which isn’t a metadata setting so much as an album setting.

This track grouping behaves very strangely, particularly on soundtracks.

Are you actively setting Work and Part Tags in an external editor, I sometimes see the data that Roon accesses is wrong but not that often . Then I set manually. But its rare.

Tidal is more often than local though

Is multi-part grouping an option in the (…) > Edit… menu of an album? Then you can try selecting all albums at once and check in the Edit… menu if it is also available for the multiselection.

nope, it isn’t

Well that’s weird :frowning:

No I’m not, although obviously when I originally brought in my CDs I used a metadata source. It’s happening with tidal albums too, basically things like:

  • the whole album shows up as parts of a “Soundtrack Group”
  • individual tracks that have minimal relation to each other except they start with the same "name: " because they might be from the same level in a game or the same episode in a TV series.

It happens with lots of my CDs, but as I mentioned it’s particularly bad with soundtracks, so when I shuffle any of my “instrumental playlists” I end up listening to every track from a particular soundtrack (it still only plays the ones in the playlist, but all the ones that are “grouped” show up as one item in the playlist).

Not only is it annoying, but over a period of time I’ve repeatedly changed key albums so it stops happening, and then it starts happening again, so I think upgrades keep resetting it or something. Example below from the Halo3 soundtrack showing per-level grouping… Halo Reach soundtrack just groups most of the album together under one “title”.

I see it if at all in classical albums where the Work/Composition and Part/Movement get confused, I actively set Composition and Movement maunually , if Roon slips I then set Prefer Multi part Grouping to prefer file

The problem probably lies in the TiVo metadata seeing a soundtrack as a composition and the bits thereof as movements . Preferring your own metadata will help but setting it universally often doesn’t work.

It’s not updates per se, Roon often re-appraises metadata and changes it , annoying but not adjustable, album covers are a favourite target

I have the Halo3 OST but itdoesn’t do this

I guess I don’t have the feature on?

Your album has actually done the same thing, but it’s grouping the whole lot under "Halo 3: " so obviously you have slightly different metadata to me. I can see the same listing on the Tidal version (not my CD rip). If you create a playlist with Arrival and Honorable Intentions included then when you shuffle the playlist these tracks will show up as a single “item”.

I bought the files not the cd so it’s the original metadata it came with. I can’t select the individual items if I go to composition it’s the whole album.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.