Disappearing iDevice Endpoints 1.8

I’m using an iPad Pro with OS 14.3 and iPhone 6S+ as endpoints in Roon 1.8 software. Until the update they were bullet proof endpoints, one with the USB CCK to a Schiit Bifrost 2 and the other to a Marantz Receiver via HDMI on the Apple Lightning DV Adapter. After the update they disappeared from my Roon devices list until I updated apps and restarted everything - as expected with an update. That worked for a day or so then my iPhone stopped showing up as a device followed shortly after by the iPad. I restarted both devices and that didn’t work so I restarted the Roon Core iMac and everything was back up again. Not a tough fix/workaround but hopefully this won’t be a recurring problem. I wouldn’t have even mentioned it if it was just one of my iDevices that dropped but I’m reporting it because it happened to both so I want to add it to the debug list in case others are having the same issue. I’m sure these types of issues will get worked out in future updates or disappear as singular system gremlins. Thanks Roon for such great software that enhances my music listening hobby.


I have the same issue: two iPhone 6’s for endpoints… disappearing every couple of days and requiring the server app relaunch… Patiently (well, at first) waiting for a fix…


I had the same thing today. Only 1 out of 6 zones visible on my phone and also a Windows PC.

I’ve also noticed weird UI behavior once the iDevices as endpoints were back up and running. The display partially freezes up during playback at the beginning of a song and won’t show the elapsed run time, just the point where it froze. The timeline freezes, including the wave form but the song continues to play even as it moves to the next song. The play pause button seems to toggle off and on but the next and previous are frozen like the timer, wave form and song identifier. Closing and restarting the app seems to fix these intermittent freezes.

1 Like

The disappearing device issue is getting worse for me. Two days ago I had one audio zone disappear. Fixed it by rebooting Rock. This morning all but my airplay audio zones disappeared. Rebooted Rock. Now just a couple of hours later several audio zones are missing.

This does not appear to be an iPhone/iPad only issue. After the tablet/phone/Core updates that got pushed down the other day to all of my devices and after rebooting all of them. Once a day they all disappear now. I am running Roon Core on Windows 10 PC, dedicated as a Roon Core machine. My local HDMI connected receiver, my regular Allo DigiOne and my Allo DigiOne signature all disappear every morning. At first it was everything except for the two Allo machines, but today, those also disappeared and the only device it would show was the Airplay on one of my receivers. Very frustrating. I have had to reboot my Roon Core/Windows 10 PC every morning since the updates in order for it to work correctly the rest of the day.

My brother runs a Roon Core ROCK on the recommended NUC platform and has not had this issue, so it seems to be a Windows 10 and Mac based Roon Core based issue from what you all wrote and my personal experiences.

1 Like

I am having very similar problem. After upgrade to 1.8, my Mytek Brooklyn DAC+ connected via Allo Usbridge (DietPi) no longer appears in a zone list. The only thing that brings it back is restart of Roon Core ROCK. Interestingly though it is visible in Settings->Audio, it is just not there in the zone selection.

I’m having the same issue. My iPad Mini 4, iPhone 12 Pro, and the DAC (Pro-Ject Pre Box S2 Digital) connected by USB to my Allo USBridge all have been disappearing from Roon so it (like Michael Gallagher mentioned) is affecting other devices which are not Apple. When this occurs the Roon Remote app will have a button at the bottom which says “Select an audio zone”. Sometimes when I check the Audio settings on the core, the affected device will have the text “Enabling” in red. However, it never completes enabling the device. Other times, a device will appear fine in Audio settings in core, but doesn’t appear in the Zone switching menu in either the core or the remotes.

This has occurred on my core on my Mac Mini (Late 2014) running Big Sur. I then changed my core to my Windows 10 Pro computer to see if I could isolate the issue to my Mac, and experienced the same issues on my Window PC.

Same here iPhone6 doesn’t show up in the Zones list and there is no way to get it to discover it once missing.

For me it helps if I restart Roon Core

Same issue. MBP → Chord Mojo. Keeps disappearing. Restarting Roon core (running ROCK) makes it reappear. Same as others; settings > audio shows the Mojo enabled.

I am having the same issue with an iPhone XR. The Roon server is running in a docker container on Debian Linux. I never had this issue with 1.7.

I have found that uninstalling and reinstalling on iOS fixes it for awhile. Obviously this is unacceptable. I’ve had to start using Neutron for playback on my phone.

I’m running Roon Rock on a NUC and have to restart almost daily to get back devices that have disappeared.

Yes, mine behaves the same way. Every time this happens, I can still see all of my devices under the settings/audio tab, but not under the zone selection area. The only thing that never disappears is the Airplay on one of my surround receivers.

Seems like a large problem…

Tired of restarting 1.8 to use endpoints - Roon Software - Roon Labs Community

I think the new build (763) may have fixed this for me

1 Like

A post was merged into an existing topic: Ack, every endpoint has stopped outputting. Anyone else same issue?

I rebuilt my Rock from scratch last night and have to say nearly all my 1.8 issues have gone. The missing rock USB DAC issue is now in the past.

1 Like

After the latest core updates in the last couple of days - there actually have been two, I am now on build 764 (on Win 10) - my end points no longer disappear! Which was my main complaint. So, so far so good and hope it stays this way! :slight_smile:

If you have not updated yet, do so.