Does not play to android box

When I want to play to my android box (formuler z10 maxpro) then the music stops after 4 seconds. I installed the .apk file and than the box is seen as a core device. But strangely the stream stops playing after 4 seconds.

It does not connect to the android box the right way because when I want to use webdisplay the music stops playing.

And when I use it as a chromecast device it also does not work.

Both device have static ip now.

An Android device cannot be a core (it can only be a remote or audio device) so I don’t know what you mean by “the box is seen as a core device.” What are you using for your actual Core?

I’m amazed it plays to a non phone,/DSP Android device at all TBH.
I’m not sure if you should post in support or tinkering :slightly_smiling_face:

The box supposedly has Chromecast built in so I don’t see why Roon couldn’t stream to that and the box just playback on whatever AVR or soundbar is attached to HDMI.

The Chromecast is an “also”
“And when I use it as a chromecast device it also does not work.”

I was talking about the Android bit.

Roon to Chromecast is actually supported though so that we should be able to get working. I don’t think Roon supports installing their phone/tablet .apk on an Android TV device (or TV device running the phone/tablet Android) so the fact that doesn’t work isn’t surprising and is a moot point anyway. That’s why I focused on the Chromecast angle, but first we need some more details from the thread starter.

Android phones and tablets are usually not available as cast targets, so I don’t see how the OP should use Roon’s ChromeCast support for his needs.

Note: The Formuler Z10 Pro Max is an Android 10 device (like phones and tablets). The same manufacturer also sells the GTV running Android TV 9.0 that can actually be used as a cast target.

So I think the only way to use the Z10 as Roon endpoint is to have the Android app Roon Remote running on the device.

So I guess this is expected (not supported by the device).

I don’t understand what @Tecko71 is trying to tell us here. Therefore some questions:

  • Did you download and install the official APK file from the Roon download page?
  • What makes you think “the box is seen as a core device” instead of an endpoint?
  • “the stream stops playing after 4 seconds”: Since when? Was it related to some Roon update or possibly other changes you made on your Roon Core, network , the Z10 (changed settings, update), else?
  • Can you please explain your statement I cited above explain a bit more?
    How can it connect the wrong way? How did you try to use the web display?

It might also be worthwhile for you to check if you can add some screenshots/pictures of what you see on your devices.

i am sorry I think it is an endpoint I installed the android apk on the Z10. The Z10 is connected to the core that way. I turn on dhcp again makes no difference. By the way I did a fresh install. Used other software before.

None of the Roon apps have been written for Android TV which this box runs a variety of so I am not surprised it doesn’t work well. Being a custom variant it could be doing anything under the hood. It doesn’t support Google cast out of the box either maybe with an extra app it might.

I would look to install a Squeezebox emulator instead as they are available for ATV. Roon will see that if you enable squeezebox support in settings. I used my Nvdia Shield this way for a while when I had no other device free. It worked ok.

1 Like

This appears to be what Tecko71 has:

If that’s the case, it isn’t Android TV. At least not according to the specs:

Operating System : Android 10

This wouldn’t be the first TV box to use the phone version of Android instead of the TV version.

That squeezebox option works. I installed sbplayer on z10 from the store.


Now there is a Chromecast showing up (how comes?) but giving that zone the same name as the Roon (RAAT) zone is probably not helpful.


Anyway, the OS on this set-top box is likely heavily modified, so nothing has to work as expected or at all.

both do not work zo turned it of and use squeezebox

It looks like the TV version if you look at any of the ui images. Irrelevant now though as he’s using Sbplayer instead.

Still have a question. I have the GTV also. I tested there chromecast streaming. Works fine. Why is android tv working and the Z10 not? I have an android phone and there it works also fine. Why does it on fromuler Z10, android 10 (phone version) not working?

And is it not time that Roon comes up with a android remote for android tv?

There is not the demand, the same for Apple TV would be my guess.

You can Chromecast music and get Audio and display output (if it is a Chromecast endpoint like my Shield TV) but there are no controls for this

Can you chromecast other apps to it?

yes with the GTV I can cast everything. With the Z10 I can not cast nothing. It is not available on Z10. But when I browse apps there is chromecast build-in.

I tried to cast from phone: message: Can not trust Z10 pro, software is old on device.

I installed air receiver on Z10 then I can cast normally. Website yes, but I can not enable airreceiver on Roon.